aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-06-13 15:27:07 +0000
committerKhem Raj <raj.khem@gmail.com>2018-06-14 20:25:16 -0700
commitd3b1e5602d4aecfa202933b6f383a027ff5626c3 (patch)
treefbe2f481feac50a023687d332416fde0879ed348
parent877934f93e3e5dfdb6b2426e1c8072a1c6fd843e (diff)
downloadmeta-openembedded-contrib-d3b1e5602d4aecfa202933b6f383a027ff5626c3.tar.gz
libqb: Fix build with gold
* since the upgrade to 1.0.3 more specifically since this commit: https://github.com/ClusterLabs/libqb/commit/20246f544f74866885f4d9491f74152bd95e7786#diff-67e997bcfdac55191033d57a16d1408a it was failing to build with gold * add --enable-nosection-fallback to work around the issue Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_1.0.3.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
index 73cea5e398..d857344e3f 100644
--- a/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
+++ b/meta-oe/recipes-extended/libqb/libqb_1.0.3.bb
@@ -18,6 +18,14 @@ SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \
"
S = "${WORKDIR}/git"
+# otherwise do_configure fails
+# configure:21609: checking whether linker workaround for orphan sections usable
+# configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5
+# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
+# WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
+# collect2: error: ld returned 1 exit status
+EXTRA_OECONF_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' --enable-nosection-fallback', '', d)}"
+
CFLAGS += "-pthread -D_REENTRANT"
do_configure_prepend() {
( cd ${S}