aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2020-09-18 21:27:06 +0800
committerKhem Raj <raj.khem@gmail.com>2020-09-21 08:55:57 -0700
commit7f70cce01991396b3091e1b4b55f85776746fab1 (patch)
treed2ead18d8e7eb78abe1054759758ed833bf9bbdb
parent0fd4433a241edd82eee62ec743d925be200ff0fe (diff)
downloadmeta-openembedded-contrib-7f70cce01991396b3091e1b4b55f85776746fab1.tar.gz
python3-argcomplete: add recipe 1.12.0
Tab complete all the things! Argcomplete provides easy, extensible command line tab completion of arguments for your Python script. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 61623ac98d..914359a868 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -42,6 +42,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
python3-alembic \
python3-ansi2html \
python3-ansicolors \
+ python3-argcomplete \
python3-argexec \
python3-appdirs \
python3-apply-defaults \
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb
new file mode 100644
index 0000000000..dd749dd9eb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
+HOMEPAGE = "https://github.com/kislyuk/argcomplete"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
+
+SRC_URI[md5sum] = "47e2a3db821f57165be8f3d3ec1e5259"
+SRC_URI[sha256sum] = "2fbe5ed09fd2c1d727d4199feca96569a5b50d44c71b16da9c742201f7cc295c"
+
+PYPI_PACKAGE = "argcomplete"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+