aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-01-16 08:56:50 -0800
committerTim Orling <tim.orling@konsulko.com>2022-01-16 08:58:36 -0800
commit9b0261d874d90a210ce08286a4798153c189d459 (patch)
tree941bf9afc84102565dd5abd1103b1471d623928a
parent825cd13a8d0c49eec7e069f462e07563c5b8a810 (diff)
downloadmeta-openembedded-contrib-9b0261d874d90a210ce08286a4798153c189d459.tar.gz
python3-pytest-forked: add recipe for 1.4.0
https://github.com/pytest-dev/pytest-forked Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
new file mode 100644
index 0000000000..28395f21a8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "run tests in isolated forked subprocesses"
+DESCRIPTION = "this is a extraction of the xdist --forked module"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-forked"
+BUGTRACKER = "https://github.com/pytest-dev/pytest-forked/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+
+SRC_URI[sha256sum] = "8b67587c8f98cbbadfdd804539ed5455b6ed03802203485dd2f53c1422d7440e"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += "python3-py python3-pytest"
+
+BBCLASSEXTEND = "native nativesdk"