aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-07-15 08:59:46 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:47 +0200
commit27981cbef19db115fa81704468721580dedfb1fd (patch)
treeb86f685c5abd3ed05c30251c651039248440d3ee
parent717fe1ff766f71f18a2d80f23baec39fb79117e2 (diff)
downloadmeta-openembedded-contrib-27981cbef19db115fa81704468721580dedfb1fd.tar.gz
vsftpd: fix install warning
WARNING: QA Issue: vsftpd: Files/directories were installed but not shipped /run /run/vsftpd /run/vsftpd/empty Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb
index 0698a63258..5df8211569 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.0.bb
@@ -70,7 +70,11 @@ do_install() {
sed -i "s:/lib/security:${base_libdir}/security:" ${D}${sysconfdir}/pam.d/vsftpd
sed -i "s:ftpusers:vsftpd.ftpusers:" ${D}${sysconfdir}/pam.d/vsftpd
fi
- install -d ${D}${localstatedir}/run/vsftpd/empty
+ if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${sysconfdir}/tmpfiles.d
+ echo "d /var/run/vsftpd/empty 0755 root root -" \
+ > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
+ fi
}
INITSCRIPT_PACKAGES = "${PN}"
@@ -82,3 +86,13 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp
--shell /bin/false ftp "
GROUPADD_PARAM_${PN} = "-r ftp"
+pkg_postinst_${PN}() {
+ if [ -n "$D" ]; then
+ exit 0
+ fi
+ if type systemd-tmpfiles >/dev/null; then
+ systemd-tmpfiles --create
+ elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
+ ${sysconfdir}/init.d/populate-volatile.sh update
+ fi
+}