aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-18 17:15:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-24 15:31:50 +0200
commitd98907203cc2653eee1db998e30d129c9c9a063a (patch)
treeaa942bf377f455d06d7120da61acaf85bb80f442
parent1a6e16bcb1145df51b15c19df0d7ef655b683f5e (diff)
downloadmeta-openembedded-contrib-d98907203cc2653eee1db998e30d129c9c9a063a.tar.gz
syslog-ng: Various fixes
* Add PACKAGECONFIG for floating json dependency * Add PACKAGECONFIG for floating tcp-wrappers dependency * Disable mongodb host infection problem * Disable rabbitmq host infection problem * Add patch for dbi host include flags issue (making dbi conditionall really work) * Fix configure automake flags handling Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.patch31
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/dbifix.patch20
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc4
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb2
4 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.patch b/meta-oe/recipes-support/syslog-ng/files/configure.patch
new file mode 100644
index 0000000000..136bb5eb1d
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/files/configure.patch
@@ -0,0 +1,31 @@
+Index: syslog-ng-3.5.4.1/configure.ac
+===================================================================
+--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 13:49:36.794141441 +0000
++++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 14:23:57.738197606 +0000
+@@ -8,15 +8,16 @@
+ dnl BINARY_BRANCH - the value is added to all source/binary packages
+ dnl SOURCE_REVISION - Revision of the source-tree, will added to the version string
+ dnl
+-AC_INIT(syslog-ng/main.c)
++AC_INIT(syslog-ng, 3.5.4.1)
++AC_CONFIG_SRCDIR(syslog-ng/main.c)
+ AC_CONFIG_MACRO_DIR([m4])
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ dnl ***************************************************************************
+ dnl definitions
+
+ PACKAGE="syslog-ng"
+ VERSION="`cat $srcdir/VERSION`"
+
+ dnl ***************************************************************************
+ dnl dependencies
+@@ -53,7 +56,7 @@
+ CURRDATE=`date +"%a, %d %b %Y %H:%M:%S %Z"`
+ fi
+
+-AM_INIT_AUTOMAKE($PACKAGE, $VERSION, [foreign no-define subdir-objects])
++AM_INIT_AUTOMAKE([foreign no-define subdir-objects])
+ _AM_PROG_TAR([ustar])
+ if test -n "$SNAPSHOT_VERSION"; then
+ VERSION=$VERSION+$SNAPSHOT_VERSION
diff --git a/meta-oe/recipes-support/syslog-ng/files/dbifix.patch b/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
new file mode 100644
index 0000000000..15dfb68855
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
@@ -0,0 +1,20 @@
+Index: syslog-ng-3.5.4.1/configure.ac
+===================================================================
+--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 14:35:03.134215740 +0000
++++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 15:31:52.510308653 +0000
+@@ -576,13 +576,14 @@
+ dnl ***************************************************************************
+
+ AC_CHECK_LIB(dl, dlsym, DL_LIBS="-ldl")
++if test "x$enable_sql" != "xno"; then
+ PKG_CHECK_MODULES(LIBDBI, dbi >= $LIBDBI_MIN_VERSION, libdbi_pkgconfig_not_found="0", libdbi_pkgconfig_not_found="1")
+
+ if test "$libdbi_pkgconfig_not_found" -eq 1; then
+ dnl if libdbi has no .pc file, try it without one
+ AC_CHECK_LIB(dbi, dbi_initialize, LIBDBI_LIBS="-ldbi"; LIBDBI_CFLAGS="-I/usr/include")
+ fi
+-
++fi
+ if test "x$enable_sql" = "xauto"; then
+ AC_MSG_CHECKING(whether to enable SQL support)
+ if test "x$LIBDBI_LIBS" != "x"; then
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 01c9b202cc..3cedba65b2 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -30,6 +30,8 @@ EXTRA_OECONF = " \
--sysconfdir=${sysconfdir}/${BPN} \
--with-module-dir=${libdir}/${BPN} \
--with-sysroot=${STAGING_DIR_HOST} \
+ --with-libmongo-client=no --disable-mongodb \
+ --with-librabbitmq-client=no \
"
PACKAGECONFIG ??= "openssl \
@@ -44,6 +46,8 @@ PACKAGECONFIG[pcre] = "--enable-pcre,--disable-pcre,libpcre,"
PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi,"
PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet,"
PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp,"
+PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
+PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers,"
do_configure_prepend() {
eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
index 12b0dc32bd..d5939e4623 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
@@ -11,6 +11,8 @@ SRC_URI += " \
file://free-global-LogTemplateOptions.patch \
file://logwriter-still-free-the-unconsumed-item.patch \
file://syslog-ng-verify-the-list-before-del.patch \
+ file://configure.patch \
+ file://dbifix.patch \
"
SRC_URI[md5sum] = "ff3bf223ebafbaa92b69a2d5b729f368"