summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-01 12:08:45 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-01 12:08:45 +0200
commitf30f89fb8ac61f80b2200f3ed874919a1f850a3f (patch)
tree03ec3e9a09fa36d04463163fa6b5370404044cba
parent8a917caaa5506fa0f875202243658a1c2fe60c40 (diff)
downloadmeta-openembedded-contrib-f30f89fb8ac61f80b2200f3ed874919a1f850a3f.tar.gz
iw: add 0.9.20
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch26
-rw-r--r--meta-oe/recipes-connectivity/iw/iw_0.9.20.bb26
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch b/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch
new file mode 100644
index 0000000000..93aad026e2
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch
@@ -0,0 +1,26 @@
+Index: iw-0.9.18/version.sh
+===================================================================
+--- iw-0.9.18.orig/version.sh 2010-09-14 13:50:27.000000000 +0400
++++ iw-0.9.18/version.sh 2010-09-14 13:50:40.000000000 +0400
+@@ -5,20 +5,6 @@
+
+ echo '#include "iw.h"' > "$OUT"
+
+-if head=`git rev-parse --verify HEAD 2>/dev/null`; then
+- git update-index --refresh --unmerged > /dev/null
+- descr=$(git describe)
+-
+- # on git builds check that the version number above
+- # is correct...
+- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
+-
+- v="${descr#v}"
+- if git diff-index --name-only HEAD | read dummy ; then
+- v="$v"-dirty
+- fi
+-else
+- v="$VERSION"
+-fi
++v="$VERSION"
+
+ echo "const char iw_version[] = \"$v\";" >> "$OUT"
diff --git a/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb b/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb
new file mode 100644
index 0000000000..3e1b09b384
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "nl80211 based CLI configuration utility for wireless devices"
+HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
+
+DEPENDS = "libnl pkgconfig"
+
+SRC_URI = " \
+ http://wireless.kernel.org/download/iw/${P}.tar.bz2 \
+ file://kill-git-version-check.patch \
+ "
+
+SRC_URI[md5sum] = "1055799b544b3e08169d155bb6c21bb0"
+SRC_URI[sha256sum] = "2d665fbfbe4fd6a40159fb821518fc5337da37448416405b936a393a14cbc7d3"
+
+CFLAGS += "-DCONFIG_LIBNL20"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}