aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-10-14 23:38:13 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-15 11:42:16 -0700
commitdfc38272ff330f8a78a6db2f39f4dbd12bcf72c9 (patch)
tree29a0b011b76e4aa4863002c7a8301ca15fa96d18
parent3569d640b248032753a619076dcfe508e87d21b0 (diff)
downloadmeta-openembedded-contrib-dfc38272ff330f8a78a6db2f39f4dbd12bcf72c9.tar.gz
python3-colorama: add native and nativesdk to BBCLASSEXTEND
* python3-cmd2 depends on colorama since the first version in: commit dc66ca8495eb051e1e6de5333e36f7f8054094a1 Author: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Date: Mon Sep 2 13:22:08 2019 +0800 python-cmd2: Add python3 version Providing a python3 version of python-cmd2. has both BBCLASSEXTENDs since: commit e929ea7a18b0aa4d7767d2264d26fcc5c8dde688 Author: Binghua Guan <freebendy@gmail.com> Date: Mon Jul 23 21:29:50 2018 +0800 python-cmd2: add native and nativesdk causing: ERROR: Nothing RPROVIDES 'python3-colorama-native' (but virtual:native:/OE/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_1.3.11.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python3-colorama-native' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-colorama-native'] NOTE: Runtime target 'python3-cmd2-native' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-cmd2-native', 'python3-colorama-native'] NOTE: Runtime target 'python3-pyflakes-native' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python3-pyflakes-native', 'python3-cmd2-native', 'python3-colorama-native'] ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'ament-cmake-pyflakes', 'ament-pyflakes-native', 'python3-pyflakes-native', 'python3-cmd2-native', 'python3-colorama-native'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-colorama_0.4.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-colorama_0.4.3.bb b/meta-python/recipes-devtools/python/python3-colorama_0.4.3.bb
index 7a3f533f26..31a523b0c1 100644
--- a/meta-python/recipes-devtools/python/python3-colorama_0.4.3.bb
+++ b/meta-python/recipes-devtools/python/python3-colorama_0.4.3.bb
@@ -8,3 +8,4 @@ inherit pypi setuptools3
SRC_URI[md5sum] = "02daee502863d24112a8c05a5d69a612"
SRC_URI[sha256sum] = "e96da0d330793e2cb9485e9ddfd918d456036c7149416295932478192f4436a1"
+BBCLASSEXTEND = "native nativesdk"