aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Tworek <tworaz@tworaz.net>2019-08-18 00:00:30 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-17 22:56:49 -0700
commit2756e90e0b09c5672f61b90bda688028693d2168 (patch)
tree2414b262d6e52a335992f0cb26d73be3ccdc407d
parent1126e1e0079deb49184369646d05c3334df7f5ab (diff)
downloadmeta-openembedded-contrib-2756e90e0b09c5672f61b90bda688028693d2168.tar.gz
meta-openembedded-contrib-2756e90e0b09c5672f61b90bda688028693d2168.tar.bz2
meta-openembedded-contrib-2756e90e0b09c5672f61b90bda688028693d2168.zip
gnome-themes-standard: Update to version 3.28
This is the latest upstream stable version that has been released over a year ago. It also seems that upstream has renamed the package to gnome-themes-extra. While doing the upgrade modify the recipe to use gnomebase bbclass from oe-core. This allows us to re-use SRC_URI pattern provided by this bbclass. Signed-off-by: Piotr Tworek <tworaz@tworaz.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb (renamed from meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.22.3.bb)15
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.22.3.bb b/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
index 55ee277606..53eb32be90 100644
--- a/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.22.3.bb
+++ b/meta-oe/recipes-gnome/gnome-themes/gnome-themes-standard_3.28.bb
@@ -4,20 +4,19 @@ BUGTRACKER = "https://bugzilla.gnome.org/"
SECTION = "x11/gnome"
LICENSE = "LGPL-2.1"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
-inherit autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even distro_features_check
+# Upstream renamed this package to gnome-themes-extra at some point
+BPN = "gnome-themes-extra"
+
+inherit gnomebase gettext gtk-icon-cache upstream-version-is-even distro_features_check
ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
DEPENDS += "intltool-native gtk+"
-MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
-SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
- "
-
-SRC_URI[md5sum] = "b51c362b157b6407303d44f93c31ee11"
-SRC_URI[sha256sum] = "61dc87c52261cfd5b94d65e8ffd923ddeb5d3944562f84942eeeb197ab8ab56a"
+SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
+SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
EXTRA_OECONF = "--disable-gtk3-engine"