aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-28 18:37:06 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-29 08:14:17 -0700
commit8f5d1be19856bf1c87d2cd210a12d88ff3933cbe (patch)
treee976afe90f000fa934ed605fbb33cdea30038dc3
parent0782ea454af5b88cd686ac572c397d92e5912de4 (diff)
downloadmeta-openembedded-contrib-8f5d1be19856bf1c87d2cd210a12d88ff3933cbe.tar.gz
python3-gevent: Avoid building internal version of libev
Use the system version. Moreover, internal version is not cross compile friendly. Ends up with | cc1: error: include location "/usr/include/python3.10" is unsafe for cross-compilation [-Werror=poison-system-directories] | cc1: some warnings being treated as errors | error: command '/home/pokybuild/yocto-worker/meta-oe/build/build/tmp/work/core2-64-poky-linux/python3-gevent/21.12.0-r0/recipe-sysroot-native/usr/bin/x86_64-poky-linux/x86_64-poky-linux-gcc' failed with exit code 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_21.12.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_21.12.0.bb b/meta-python/recipes-devtools/python/python3-gevent_21.12.0.bb
index 9efeec4d9f..5cbb3268b0 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_21.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_21.12.0.bb
@@ -4,7 +4,7 @@ a high-level synchronous API on top of the libevent event loop."
HOMEPAGE = "http://www.gevent.org"
LICENSE = "MIT & Python-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
-DEPENDS += "${PYTHON_PN}-greenlet libev c-ares"
+DEPENDS += "${PYTHON_PN}-greenlet libev libuv c-ares"
RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
${PYTHON_PN}-mime \
@@ -15,8 +15,10 @@ SRC_URI[sha256sum] = "f48b64578c367b91fa793bf8eaaaf4995cb93c8bc45860e473bf868070
inherit pypi setuptools3
-# Don't embed libraries, link to the system instead
-export GEVENTSETUP_EMBED = "0"
+# Don't embed libraries, link to the system provided libs instead
+export GEVENTSETUP_EMBED_CARES = "0"
+export GEVENTSETUP_EMBED_LIBEV = "0"
+export GEVENTSETUP_EMBED_LIBUV = "0"
# Delete the embedded copies of libraries so we can't accidentally link to them
do_configure:append() {