aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYanfei Xu <yanfei.xu@windriver.com>2020-05-22 16:14:42 +0800
committerKhem Raj <raj.khem@gmail.com>2020-05-22 09:03:04 -0700
commit90bcc2bd494c2c7a0a43e1d0c4943cdd061e929d (patch)
tree55211693757b73faa3afd67d57d20442f46b3320
parent257f67186c697fe5bba36bf86cc05a637e558ca4 (diff)
downloadmeta-openembedded-contrib-90bcc2bd494c2c7a0a43e1d0c4943cdd061e929d.tar.gz
turbostat: fix the build failure for new v5.7-rc6 kernel
Due to the new v5.7-rc6 kernel has some modify in header files, turbostat build failed. Now match the files. Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb20
1 files changed, 16 insertions, 4 deletions
diff --git a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
index 60040a47af..48c72140c8 100644
--- a/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
+++ b/meta-oe/recipes-kernel/turbostat/turbostat_3.4.bb
@@ -42,16 +42,28 @@ do_configure_prepend() {
mkdir -p ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
- cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
- cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
+ if [ -f "${STAGING_KERNEL_DIR}/include/vdso/bits.h" ]; then
+ cp -r ${STAGING_KERNEL_DIR}/include/vdso/bits.h ${S}
+ cp -r ${STAGING_KERNEL_DIR}/include/vdso/const.h ${S}
+ else
+ cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
+ cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
+ fi
cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
cp -r ${WORKDIR}/COPYING ${S}
}
+
do_compile() {
sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h
- sed -i 's#<linux/const.h>#"const.h"#' bits.h
- sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
+ 'TMPCHECK='grep "<vdso/const.h>" bits.h'' || true
+ if [ -n $TMPCHECK ]; then
+ sed -i 's#<vdso/const.h>#"const.h"#' bits.h
+ sed -i 's#<uapi/linux/const.h>#<linux/const.h>#' const.h
+ else
+ sed -i 's#<linux/const.h>#"const.h"#' bits.h
+ sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
+ fi
sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile