aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/e-wm.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-08-25 15:26:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-27 12:49:20 +0200
commit46698617eb3ee7a5a2c638759654b6076a7bc058 (patch)
tree66e40e6653c7cb78ca83d9ec0e6c7b0367a41546 /meta-efl/recipes-efl/e17/e-wm.inc
parent49cb17b4978bf586311f5b8ab4b1b3810098c297 (diff)
downloadmeta-openembedded-contrib-46698617eb3ee7a5a2c638759654b6076a7bc058.tar.gz
e-wm: add git recipe with latest revision
* E19 is still in alpha stage, but I was told that many things work there better than old(ish) E18 * last announcement: https://phab.enlightenment.org/phame/live/3/post/e19_alpha2_now_with_50_more_explosions/ * but be aware that illume2 modules are gone and config mobile doesn't work without them * there is new tiling config Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/e17/e-wm.inc')
-rw-r--r--meta-efl/recipes-efl/e17/e-wm.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc
index 122a60e8b4..0ff26ef9cd 100644
--- a/meta-efl/recipes-efl/e17/e-wm.inc
+++ b/meta-efl/recipes-efl/e17/e-wm.inc
@@ -10,6 +10,8 @@ S = "${WORKDIR}/${SRCNAME}"
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
+PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
+
EXTRA_OECONF = "\
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
@@ -21,6 +23,7 @@ EXTRA_OECONF = "\
do_configure_prepend() {
autopoint || true
+ sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
}
do_install_append() {
@@ -70,6 +73,7 @@ PACKAGES =+ "\
${PN}-config-netbook \
${PN}-config-scaleable \
${PN}-config-standard \
+ ${PN}-config-tiling \
${PN}-theme-default \
${PN}-background-dark-gradient \
${PN}-background-light-gradient \
@@ -126,6 +130,7 @@ FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist
FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
FILES_${PN}-config-standard = "${datadir}/enlightenment/data/config/standard"
+FILES_${PN}-config-tiling = "${datadir}/enlightenment/data/config/tiling"
FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
FILES_${PN}-theme-default = "${datadir}/enlightenment/data/themes/default.edj"
FILES_${PN}-background-dark-gradient = "${datadir}/enlightenment/data/backgrounds/Dark_Gradient.edj"