aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/exalt_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/e17/exalt_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-contrib-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/e17/exalt_svn.bb')
-rw-r--r--meta-efl/recipes-efl/e17/exalt_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/exalt_svn.bb b/meta-efl/recipes-efl/e17/exalt_svn.bb
new file mode 100644
index 0000000000..712204fba6
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/exalt_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
+HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
+
+LICENSE = "LGPLv2"
+DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
+RDEPENDS_${PN} = "vpnc wpa-supplicant"
+
+PV = "0.9+svnr${SRCPV}"
+SRCREV = "${EFL_SRCREV}"
+PR = "r1"
+
+inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+EXTRA_OECONF = " \
+--with-wpa_supplicant=${sbindir}/wpa_supplicant \
+--with-vpnc=${sbindir}/vpnc \
+--with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
+"
+
+do_install_append() {
+ # install dbus config file
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
+
+ # install dbus service file
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
+}
+
+FILES_${PN} += "${datadir}/dbus-1"
+