aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/azy_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/efl/azy_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-contrib-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/efl/azy_svn.bb')
-rw-r--r--meta-efl/recipes-efl/efl/azy_svn.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/efl/azy_svn.bb b/meta-efl/recipes-efl/efl/azy_svn.bb
new file mode 100644
index 0000000000..c7ee1f4c96
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/azy_svn.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Azy is a library meant for implementing rpc clients and servers in a simple manner."
+DEPENDS = "pkgconfig zlib openssl eina gnutls ecore libxml2 re2c-native mysql5 azy-native"
+DEPENDS_virtclass-native = "pkgconfig-native zlib-native openssl-native eina-native gnutls-native ecore-native libxml2-native re2c-native mysql5-native"
+LICENSE = "LGPLv2.1+"
+PV = "1.0.0+svnr${SRCPV}"
+SRCREV = "${EFL_SRCREV}"
+
+# to provide native lemon binary
+BBCLASSEXTEND = "native"
+
+do_configure_prepend() {
+ sed -i "s#\./lemon#${STAGING_BINDIR_NATIVE}/lemon#g" ${S}/src/bin/Makefile.am
+ sed -i "s#\$(top_builddir)/src/bin/azy_parser -H -p -o#${STAGING_BINDIR_NATIVE}/azy_parser -H -p -o#g" ${S}/src/tests/Makefile.am
+ sed -i "s#\$(top_builddir)/src/bin/azy_parser -eHn -m#${STAGING_BINDIR_NATIVE}/azy_parser -eHn -m#g" ${S}/src/tests/identi.ca/Makefile.am
+}
+do_configure_virtclass-native() {
+ efl_do_configure
+}
+
+do_install_append_virtclass-native() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/src/bin/lemon ${D}/${bindir}
+}
+
+inherit efl
+
+SRC_URI = "${E_SVN}/trunk/PROTO;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+