aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-05 21:55:25 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-06 13:14:00 +0200
commit2fda20563d1dd813eb3fe412831c901f131d3cd2 (patch)
tree8de52ddd21342dcc905a5e5be50208db6edec7cd /meta-efl/recipes-efl/packagegroups
parentba89801d4dc6b7c79d2f0e333e424d14a64c786a (diff)
downloadmeta-openembedded-contrib-2fda20563d1dd813eb3fe412831c901f131d3cd2.tar.gz
task-x11-illume: rename to packagegroup-x11-illume
* add RPROVIDES/RREPLACES/RCONFLICTS task-x11-illume for upgrade path * RDEPEND on packagegroup-core-x11* from oe-core now with task-x11-* gone from meta-oe Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/packagegroups')
-rw-r--r--meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
new file mode 100644
index 0000000000..11b01f6a9f
--- /dev/null
+++ b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "The Illume Windowing Environment -- install this task to get the Enlightenment Window Manager + the Illume environment."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${TOPDIR}/meta-openembedded/meta-efl/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PV = "1.0"
+PR = "r5"
+
+inherit packagegroup allarch
+
+# Default theme and config
+ETHEME ?= "e-wm-theme-default"
+ECONFIG ?= "e-wm-config-mobile"
+
+RPROVIDES_${PN} += "task-x11-illume"
+RREPLACES_${PN} += "task-x11-illume"
+RCONFLICTS_${PN} += "task-x11-illume"
+RDEPENDS_${PN} = "\
+ packagegroup-core-x11-xserver \
+ packagegroup-core-x11-utils \
+ \
+ e-wm \
+ ${ECONFIG} \
+ ${ETHEME} \
+"