aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/webkit
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-06-06 11:17:30 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-08 08:31:35 +0200
commita41e8f8612bfbd48f0abcf9b9897660796958c64 (patch)
tree6b5566332fd7864defe441442b2af864c389d768 /meta-efl/recipes-efl/webkit
parentb6e2e3bb4d9c4a38657168a75473d48181451be3 (diff)
downloadmeta-openembedded-contrib-a41e8f8612bfbd48f0abcf9b9897660796958c64.tar.gz
webkit-efl: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
* currently it doesn't build with default pkg-config from oe-core http://lists.linuxtogo.org/pipermail/openembedded-core/2011-June/003798.html if build pkg-config-native before this patch http://cgit.freedesktop.org/pkg-config/commit/?id=69a7eaa6763bb0920e2b539fffbad51348d94deb then webkit-efl builds fine again Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/webkit')
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch19
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_svn.bb42
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
new file mode 100644
index 0000000000..966a977ee4
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/revert.r78057.patch
@@ -0,0 +1,19 @@
+see https://bugs.webkit.org/show_bug.cgi?id=50762
+fixed by:
+http://trac.webkit.org/changeset/78047/trunk/Source/WebCore/CMakeLists.txt
+fix reverted by:
+http://trac.webkit.org/changeset/78057/trunk/Source/WebCore/CMakeLists.txt
+
+so revert revert as we care about webkit-efl and don't care about WinCE
+
+Index: Source/WebCore/CMakeLists.txt
+===================================================================
+--- Source/WebCore/CMakeLists.txt (revision 78042)
++++ Source/WebCore/CMakeLists.txt (revision 78047)
+@@ -1157,6 +1157,4 @@
+
+ platform/Arena.cpp
+- platform/ContextMenu.cpp
+- platform/ContextMenuItem.cpp
+ platform/ContentType.cpp
+ platform/CrossThreadCopier.cpp
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
new file mode 100644
index 0000000000..ee1e18d723
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_svn.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Webkit browser engine, EFL edition"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
+ file://JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
+ file://WebKit/efl/ewk/EWebKit.h;endline=20;md5=55ea170b1582797d2c69712de850f2fa \
+"
+
+DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
+ libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
+ libxml2 pango eina ecore evas edje"
+
+SRCREV = "79192"
+PV = "1.3.11+svnr${SRCPV}"
+
+SRCREV_FORMAT = "source"
+
+SRC_URI = "\
+ svn://svn.webkit.org/repository/webkit/trunk;module=Source;name=source;proto=http;subdir=src \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=Tools;proto=http;subdir=src \
+ file://revert.r78057.patch \
+ "
+
+S = "${WORKDIR}/src/Source"
+
+inherit cmake lib_package pkgconfig
+
+# Wants to jump too far for THUMB on armv4t
+# in WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)':
+# DocTypeStrings.cpp:(.text._ZN7WebCore18DocTypeStringsHash21doctype_hash_functionEPKcj[WebCore::DocTypeStringsHash::doctype_hash_function(char const*, unsigned int)]+0x12): relocation truncated to fit: R_ARM_THM_CALL against symbol `__gnu_thumb1_case_uhi' defined in .text section in x86_64-linux/usr/armv4t/lib/gcc/arm-oe-linux-gnueabi/4.5.2/libgcc.a(_thumb1_case_uhi.o)
+# the same in WebCore::CSSValueKeywordsHash::value_hash_function(char const*, unsigned int)':
+# WebCore::CSSPropertyNamesHash::propery_hash_function(char const*, unsigned int)':
+# WebCore::ColorDataHash::colordata_hash_function(char const*, unsigned int)':
+ARM_INSTRUCTION_SET = "ARM"
+
+EXTRA_OECMAKE = "-DPORT=Efl -DSHARED_CORE=ON"
+
+LEAD_SONAME = "libewebkit.so"
+PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
+
+FILES_${PN} += "${datadir}/webkit-1.0/theme/default.edj ${datadir}/ewebkit-0/themes/default.edj"
+FILES_${PN}launcher = "${bindir}/EWebLauncher"
+FILES_${PN}launcher-dbg = "${bindir}/.debug/EWebLauncher"