aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-20 17:53:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:15 +0100
commitf696e1bdb10f7b2cb139bf9048e478d9f10c5e17 (patch)
tree9396813287e6628763db21469033e458595446a5 /meta-efl
parent62526723c7d8bd2687ebd02bcc3ecb48769d9c8c (diff)
downloadmeta-openembedded-contrib-f696e1bdb10f7b2cb139bf9048e478d9f10c5e17.tar.gz
e-wm: Add recipe for 0.18.2
* keep old 0.17.* around because new enlightenment is more picky on where it will run (compositor is now mandatory) * 0.18.2 release: http://sourceforge.net/mailarchive/message.php?msg_id=31789335 * 0.18.3 release: http://sourceforge.net/mailarchive/message.php?msg_id=31895179 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/e17/e-wm.inc14
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_0.17.5.bb12
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_0.18.3.bb20
3 files changed, 35 insertions, 11 deletions
diff --git a/meta-efl/recipes-efl/e17/e-wm.inc b/meta-efl/recipes-efl/e17/e-wm.inc
index 3f24b62c59..08fe25fce6 100644
--- a/meta-efl/recipes-efl/e17/e-wm.inc
+++ b/meta-efl/recipes-efl/e17/e-wm.inc
@@ -7,7 +7,8 @@ SRCNAME = "e"
inherit e update-alternatives gettext
S = "${WORKDIR}/${SRCNAME}"
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
EXTRA_OECONF = "\
@@ -30,16 +31,6 @@ do_install_append() {
# xinit[418]: ERROR: CONFIGURATION FILE HAS BAD PERMISSIONS
chmod 600 ${D}/${sysconfdir}/enlightenment/sysactions.conf
- install -d ${D}/${datadir}/applications/
- install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop
- sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop
- echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop
- echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop
- echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop
- echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop
- install -d ${D}/${datadir}/icons/
- install -m 644 ${S}/data/themes/img/O/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png
-
install -d ${D}/${sysconfdir}/xdg/menus
install -m 644 ${WORKDIR}/applications.menu ${D}/${sysconfdir}/xdg/menus/
for I in `find ${D}/${libdir}/enlightenment -name "*.a" -print`; do rm -f $I; done
@@ -124,6 +115,7 @@ FILES_${PN} = "\
${datadir}/enlightenment/COPYING \
${datadir}/xsessions/enlightenment.desktop \
${sysconfdir}/xdg \
+ ${systemd_unitdir} \
"
FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb b/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb
index 57eefdb4d8..d374680fbb 100644
--- a/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_0.17.5.bb
@@ -12,3 +12,15 @@ SRC_URI = "\
SRC_URI[md5sum] = "5aefb55df0b1a0a0ae0cf9d0610cf7c7"
SRC_URI[sha256sum] = "25d4967277cf27d4efb474a9b8eceb1200aa813a51c248b61cc23f69291bff0f"
+
+do_install_append() {
+ install -d ${D}/${datadir}/applications/
+ install -m 644 ${S}/src/modules/fileman/module.desktop ${D}/${datadir}/applications/efm.desktop
+ sed "s#Type=Link#Type=Application#g" -i ${D}/${datadir}/applications/efm.desktop
+ echo "Exec=enlightenment_remote -efm-open-dir" >> ${D}/${datadir}/applications/efm.desktop
+ echo "Terminal=false" >> ${D}/${datadir}/applications/efm.desktop
+ echo "Categories=Application;" >> ${D}/${datadir}/applications/efm.desktop
+ echo "StartupNotify=true" >> ${D}/${datadir}/applications/efm.desktop
+ install -d ${D}/${datadir}/icons/
+ install -m 644 ${S}/data/themes/img/O/icon_icon_theme.png ${D}/${datadir}/icons/e-module-fileman.png
+}
diff --git a/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb b/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb
new file mode 100644
index 0000000000..ae21cc14e7
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/e-wm_0.18.3.bb
@@ -0,0 +1,20 @@
+require ${BPN}.inc
+
+SRCNAME = "enlightenment"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI = "\
+ ${E_RELEASES}/apps/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
+ file://enlightenment_start.oe \
+ file://applications.menu \
+"
+
+SRC_URI[md5sum] = "9f6e6c296b88b038ac05415006c678fd"
+SRC_URI[sha256sum] = "17d207246bf10dec5a5fa854da5763e0e6dd61decde3474ff5fedffbb9dc8629"
+
+do_configure_prepend() {
+ sed '/^ *EFL_PKG_CHECK_VAR/ s/systemduserunitdir/systemdsystemunitdir/g' -i ${S}/configure.ac
+}
+
+PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"