aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-04 18:27:34 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 01:52:57 +0100
commit7199752c68171a21a888b39d4a7862085b4f0253 (patch)
tree72da635de0198814d73e2a394dd28360256a7d6e /meta-efl
parentc08c78bb97854e326248dfea913f801452471cb6 (diff)
downloadmeta-openembedded-contrib-7199752c68171a21a888b39d4a7862085b4f0253.tar.gz
python-efl: fix do_configure_prepend to be reentrant
* without '=' it added ${STAGING_DIR_HOST} prefix again when do_configure was executed twice in the same WORKDIR causing issues when looking for header files in python-edje, python-ecore, python-elementary and python-emotion ./python-edje/configure.ac:CYTHON_EDJE_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"` ./python-ecore/configure.ac:CYTHON_ECORE_EVAS_INCLUDEDIR="" ./python-ecore/configure.ac:CYTHON_ECORE_EVAS_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"` ./python-elementary/configure.ac:CYTHON_ELEMENTARY_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"` ./python-emotion/configure.ac:CYTHON_EMOTION_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"` * config.log diffs confirms duplicated ${STAGING_DIR_HOST} prefix < CYTHON_ECORE_EVAS_INCLUDEDIR='/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/usr/include/python-evas' --- > CYTHON_ECORE_EVAS_INCLUDEDIR='/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/usr/include/python-evas' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index 77d4114ca7..2bcc434950 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -6,7 +6,7 @@ AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
# the extension modules.
DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
RDEPENDS_${PN} += "python-lang"
-INC_PR = "r0"
+INC_PR = "r1"
# necessary to let the call for python-config succeed
export BUILD_SYS
@@ -24,7 +24,7 @@ S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
do_configure_prepend() {
# prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
- sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+ sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
}
do_install_append() {