aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-28 15:25:37 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-28 16:35:00 -0700
commit20cea78248b9d8fc47de731d25b4ea26ffa9103b (patch)
tree727a033f6fdd4a243e607310f87d5120768ea121 /meta-filesystems/recipes-filesystems
parent98353572fa7298b5098b0cb48993ab37373dbccc (diff)
downloadmeta-openembedded-contrib-20cea78248b9d8fc47de731d25b4ea26ffa9103b.tar.gz
zfs: Fix build with aarch64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch35
-rw-r--r--meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb6
2 files changed, 28 insertions, 13 deletions
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch b/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch
index f682a412ae..bcca56347c 100644
--- a/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch
+++ b/meta-filesystems/recipes-filesystems/zfs/zfs/aaf28a4630af60496c9d33db1d06a7d7d8983422.patch
@@ -32,23 +32,36 @@ fixes the following error
/mnt/b/yoe/master/build/tmp/work/imx8qm_var_som-yoe-linux/zfs/2.1.9-r0/build/../zfs-2.1.9/module/zfs/vdev_raidz_math_impl.h:1360:9: note: in expansion of macro 'REC_PQR_DEFINE'
1360 | REC_PQR_DEFINE();
+Upstream-Status: Pending [https://github.com/BrainSlayer/zfs/commit/aaf28a4630af60496c9d33db1d06a7d7d8983422]
Signed-off-by: Sebastian Gottschall <s.gottschall@dd-wrt.com>
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
-Source: https://github.com/BrainSlayer/zfs/commit/aaf28a4630af60496c9d33db1d06a7d7d8983422
-
module/Kbuild.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- a/module/Kbuild.in
+++ b/module/Kbuild.in
-@@ -44,4 +44,10 @@ endif
- subdir-asflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS)
- subdir-ccflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS)
+@@ -57,9 +57,9 @@ asflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_
+ ccflags-y := $(ZFS_MODULE_CFLAGS) $(ZFS_MODULE_CPPFLAGS)
-+ifeq ($(CONFIG_ARM64),y)
-+CFLAGS_REMOVE_zfs_fletcher_aarch64_neon.o = -mgeneral-regs-only
-+CFLAGS_REMOVE_vdev_raidz_math_aarch64_neon.o = -mgeneral-regs-only
-+CFLAGS_REMOVE_vdev_raidz_math_aarch64_neonx2.o = -mgeneral-regs-only
-+endif
-+
+ ifeq ($(CONFIG_ARM64),y)
+-CFLAGS_REMOVE_zcommon/zfs_fletcher_aarch64_neon.o += -mgeneral-regs-only
+-CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neon.o += -mgeneral-regs-only
+-CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neonx2.o += -mgeneral-regs-only
++CFLAGS_REMOVE_zcommon/zfs_fletcher_aarch64_neon.o = -mgeneral-regs-only
++CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neon.o = -mgeneral-regs-only
++CFLAGS_REMOVE_zfs/vdev_raidz_math_aarch64_neonx2.o = -mgeneral-regs-only
endif
+
+ # Suppress unused-value warnings in sparc64 architecture headers
+--- a/META
++++ b/META
+@@ -1,7 +1,7 @@
+ Meta: 1
+ Name: zfs
+ Branch: 1.0
+-Version: 2.1.99
++Version: 2.1.11
+ Release: 1
+ Release-Tags: relext
+ License: CDDL
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb
index be1e60be7c..942f5f9de1 100644
--- a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb
+++ b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.11.bb
@@ -4,11 +4,13 @@ LICENSE = "CDDL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7087caaf1dc8a2856585619f4a787faa"
HOMEPAGE ="https://github.com/openzfs/zfs"
-SRC_URI = "https://github.com/openzfs/zfs/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
+SRCREV = "0f03a411615a797425de488eecfaaf63fc41acfe"
+SRC_URI = "git://github.com/openzfs/zfs;protocol=https;branch=master \
file://0001-Define-strndupa-if-it-does-not-exist.patch \
file://aaf28a4630af60496c9d33db1d06a7d7d8983422.patch \
"
-SRC_URI[sha256sum] = "a54fe4e854d0a207584f1799a80e165eae66bc30dc8e8c96a1f99ed9d4d8ceb2"
+
+S = "${WORKDIR}/git"
# Using both 'module' and 'autotools' classes seems a bit odd, they both
# define a do_compile function.