aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
authorWindel Bouwman <windel.bouwman@gmail.com>2022-05-06 08:55:12 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-06 09:21:39 -0700
commitda8a50684ad87a7937bf9242c0bc831ad5b2f544 (patch)
treefa34e55e0d07a62d2cd68285fea2e9b1f351b6a5 /meta-filesystems/recipes-filesystems
parent0716b34c88e47458ef2d068474ddabfdca7fc779 (diff)
downloadmeta-openembedded-contrib-da8a50684ad87a7937bf9242c0bc831ad5b2f544.tar.gz
Add zfs recipe
Signed-off-by: Windel Bouwman <windel@windel.nl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb
new file mode 100644
index 0000000000..072af79019
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/zfs/zfs_2.1.4.bb
@@ -0,0 +1,54 @@
+
+SUMMARY = "OpenZFS on Linux and FreeBSD"
+DESCRIPTION = "OpenZFS on Linux and FreeBSD"
+LICENSE = "CDDL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7087caaf1dc8a2856585619f4a787faa"
+HOMEPAGE ="https://github.com/openzfs/zfs"
+
+SRC_URI = "https://github.com/openzfs/zfs/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz"
+SRC_URI[sha256sum] = "3b52c0d493f806f638dca87dde809f53861cd318c1ebb0e60daeaa061cf1acf6"
+
+# Using both 'module' and 'autotools' classes seems a bit odd, they both
+# define a do_compile function.
+# That's why we opt for module-base, also this prevents module splitting.
+inherit module-base pkgconfig autotools
+
+DEPENDS = "virtual/kernel zlib util-linux libtirpc openssl curl"
+
+PACKAGECONFIG[pam] = "--enable-pam --with-pamconfigsdir=${datadir}/pam-configs --with-pammoduledir=${libdir}/security, --disable-pam"
+
+EXTRA_OECONF:append = " \
+ --disable-pyzfs \
+ --with-linux=${STAGING_KERNEL_DIR} --with-linux-obj=${STAGING_KERNEL_BUILDDIR} \
+ --with-mounthelperdir=${base_sbin} \
+ --with-udevdir=${base_libdir}/udev \
+ --enable-systemd \
+ --disable-sysvinit \
+ --without-dracutdir \
+ "
+
+EXTRA_OEMAKE:append = " \
+ INSTALL_MOD_PATH=${D}${root_prefix} \
+ "
+
+do_install:append() {
+ # /usr/share/zfs contains the zfs-tests folder which we do not need:
+ rm -rf ${D}${datadir}/zfs
+
+ rm -rf ${D}${datadir}/initramfs-tools
+}
+
+FILES:${PN} += "\
+ ${base_sbindir}/* \
+ ${base_libdir}/* \
+ ${sysconfdir}/* \
+ ${sbindir}/* \
+ ${bindir}/* \
+ ${libexecdir}/${BPN}/* \
+ ${libdir}/* \
+ "
+
+FILES:${PN}-dev += "\
+ ${prefix}/src/zfs-${PV}/* \
+ ${prefix}/src/spl-${PV}/* \
+ "