aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-06-19 15:09:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 12:20:19 +0200
commitfeff44226210053d786278161dcb4e7b826ece12 (patch)
treef06e578d10f4f096aceeb5dec1b09b43651ecd96 /meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb
parent0de19c01c57ad2ec978c988c89fbb24a429a6d59 (diff)
downloadmeta-openembedded-contrib-feff44226210053d786278161dcb4e7b826ece12.tar.gz
aufs-util: add new recipe
Introducing the aufs-util target recipe. This would be used in conjuction with the aufs kernel feature to provide union mounts suitable for live boot applications. Only the target binaries are currently packages, with man pages, libraries and other artifacts skipped in this initial integration. (Integration work done by Bruce Ashfield <bruce.ashfield@windriver.com> and Chen Qi <Qi.Chen@windriver.com> .) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb')
-rw-r--r--meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb
new file mode 100644
index 0000000000..48c545660d
--- /dev/null
+++ b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb
@@ -0,0 +1,53 @@
+SUMMARY = "Tools for managing AUFS mounts"
+SECTION = "base"
+HOMEPAGE = "http://aufs.sourceforge.net/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
+
+DEPENDS = "aufs-util-native"
+DEPENDS_class-native = ""
+
+SRCREV = "f29056fe396d56fc2a06a96312feabaebbe14c59"
+SRC_URI = "git://git.code.sf.net/p/aufs/aufs-util;protocol=git;branch=aufs3.9 \
+ file://aufs-util-don-t-strip-executables.patch \
+ file://aufs-util-add-tool-concept-to-Makefile-for-cross-com.patch \
+ file://aufs_type.h \
+"
+
+PV = "3.9+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+do_configure_append () {
+ install -d ${S}/include/linux/
+ cp ${WORKDIR}/aufs_type.h ${S}/include/linux/
+}
+
+do_configure_append_class-target () {
+ for i in ver c2sh c2tmac; do
+ cp ${STAGING_BINDIR_NATIVE}/aufs-util-${PV}/$i ./
+ done
+}
+
+do_compile () {
+ oe_runmake CPPFLAGS="-I${S}/include -I${S}/libau"
+}
+
+do_compile_class-native () {
+ oe_runmake tools CPPFLAGS="-I${S}/include -I${S}/libau"
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install_sbin install_ubin install_etc
+}
+
+do_install_class-native () {
+ install -d ${D}${bindir}/aufs-util-${PV}
+ for i in ver c2sh c2tmac; do
+ install -m 755 $i ${D}${bindir}/aufs-util-${PV}/$i
+ done
+}
+
+RRECOMMENDS_${PN} += "kernel-module-aufs"
+
+BBCLASSEXTEND = "native"