aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-17 13:17:53 -0700
committerKhem Raj <raj.khem@gmail.com>2019-08-17 13:22:58 -0700
commit28f0b48c6f58219279690f3c16cde62724aa824f (patch)
tree3595735cf1aa645ef8a468095037dcb0c0846cc6 /meta-filesystems
parent38f6350def0f29697e9e67d544e1938a483f25b2 (diff)
downloadmeta-openembedded-contrib-28f0b48c6f58219279690f3c16cde62724aa824f.tar.gz
ufs-tool: Do not force static linking
build forced static linking if it detect cross-compilation, static linking with glibc does not work in all circumstances, e.g. when using clang, glibc expects libgcc to be linked in to provide unwinding, which may not be the case, ideally the symbols should be looked up independent of libraries linked in but thats not the case fixes | /mnt/a/yoe/build/tmp/work/cortexa7t2hf-neon-vfpv4-yoe-linux-gnueabi/ufs-tool/1.3+gitAUTOINC+8b00e33003-r0/recipe-sysroot-native/usr/bin/arm-yoe-linux-gnueabi/arm-yoe-linux-gnueabi-ld: /mnt/a/yoe/build/tmp/work/cortexa7t2hf-neon-vfpv4-yoe-linux-gnueabi/ufs-tool/1.3+gitAUTOINC+8b00e33003-r0/recipe-sysroot/usr/lib//arm-yoe-linux-gnueabi/9.2.0/../../../lib/libpthread.a(unwind.o): in function `__pthread_unwind': | /usr/src/debug/glibc/2.30-r0/git/nptl/unwind.c:121: undefined reference to `_Unwind_ForcedUnwind' | clang-9: error: linker command failed with exit code 1 (use -v to see invocation) | make: *** [Makefile:40: ufs-tool] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
index e074b51971..208ac3c58b 100644
--- a/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
+++ b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
@@ -12,8 +12,11 @@ SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}""
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}""
+do_configure() {
+ sed -i -e "s|-static$||g" ${S}/Makefile
+}
do_install() {
install -d ${D}${bindir}/
install -c -m 755 ${S}/ufs-tool ${D}${bindir}/