aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-11 08:10:53 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:13:25 +0200
commit80f47fd89294c7ffa17b74f0fd8ec22811d41637 (patch)
tree6968bacb2cc702f91fd8806afa988512f958bcec /meta-filesystems
parent73b8d2a90909dd76352745732b33ff237bc361c5 (diff)
downloadmeta-openembedded-contrib-80f47fd89294c7ffa17b74f0fd8ec22811d41637.tar.gz
xfsdump: Upgrade to 3.1.7
Fix build on musl Point to new SRC_URI Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/xfsdump/files/0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch28
-rw-r--r--meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.7.bb (renamed from meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.6.bb)7
2 files changed, 32 insertions, 3 deletions
diff --git a/meta-filesystems/recipes-utils/xfsdump/files/0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch b/meta-filesystems/recipes-utils/xfsdump/files/0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch
new file mode 100644
index 0000000000..1fe1bde8bd
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsdump/files/0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch
@@ -0,0 +1,28 @@
+From f1e822d546e08cc195eaeb38ca172bd0c3800aa9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 9 Sep 2017 07:48:48 -0700
+Subject: [PATCH] xfsdump: Use c99 defined int64_t instead of __int64_t
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ common/hsmapi.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/common/hsmapi.c b/common/hsmapi.c
+index 6054773..0709dbe 100644
+--- a/common/hsmapi.c
++++ b/common/hsmapi.c
+@@ -585,7 +585,7 @@ HsmModifyExtentMap(
+ struct getbmapx *bmap)
+ {
+ dmf_f_ctxt_t *dmf_f_ctxtp = (dmf_f_ctxt_t *)contextp;
+- __int64_t length;
++ int64_t length;
+
+ if (bmap[0].bmv_entries <= 0) {
+ return 1; /* caller must already be at EOF */
+--
+2.14.1
+
diff --git a/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.6.bb b/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.7.bb
index d1033cff15..0ac991b238 100644
--- a/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.6.bb
+++ b/meta-filesystems/recipes-utils/xfsdump/xfsdump_3.1.7.bb
@@ -10,16 +10,17 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc"
DEPENDS = "xfsprogs attr"
-SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${BPN}-${PV}.tar.gz \
+SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
file://remove-install-as-user.patch \
file://0001-Include-fcntl.h-for-O_EXCL.patch \
file://0002-Replace-__uint32_t-with-uint32_t.patch \
file://0003-replace-use-of-SIGCLD-with-SIGCHLD.patch \
file://0004-include-limit.h-for-PATH_MAX.patch \
file://0005-include-sys-types.h-for-u_int32_t-in-attr-attributes.patch \
+ file://0001-xfsdump-Use-c99-defined-int64_t-instead-of-__int64_t.patch \
"
-SRC_URI[md5sum] = "50353cd4f4b435685955363e6044f4d1"
-SRC_URI[sha256sum] = "7f78c11ca527477d90e5e62b0778f3ad96f2b71c19173044e9aca9515fff42d0"
+SRC_URI[md5sum] = "c6e91f2ac8b76c796db2d236f5ca5947"
+SRC_URI[sha256sum] = "99e6d4df257ebc6d29ca9e970ca20672c2ea03481ad949bc68f98de3e4d56dce"
inherit autotools-brokensep