aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/bonobo
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-03 19:30:40 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-03 19:30:40 +0200
commit821c42c7f95a9d12de38e4153514f99f4d3323ca (patch)
tree44b46df95bcd264ead9b599d5ce1bf94a5e4a820 /meta-gnome/recipes-gnome/bonobo
parent3e32248ba1f25def2b4182c9f29661a79ad597e3 (diff)
downloadmeta-openembedded-contrib-821c42c7f95a9d12de38e4153514f99f4d3323ca.tar.gz
libbonobo: import from OE rev 7ae56b81f8cc22f9ef13a48cde000e32138948ea
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/bonobo')
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo.inc40
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo/configure-gthread.patch11
-rw-r--r--meta-gnome/recipes-gnome/bonobo/libbonobo_2.24.3.bb3
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo.inc b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
new file mode 100644
index 0000000000..b4f72d7be1
--- /dev/null
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo.inc
@@ -0,0 +1,40 @@
+DESCRIPTION = "Bonobo CORBA interfaces library"
+LICENSE = "GPLv2 && LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
+SECTION = "x11/gnome/libs"
+DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
+
+inherit gnome
+
+SRC_URI += "file://gtk-doc.m4 \
+ file://gtk-doc.make \
+ "
+
+ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so"
+FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug \
+ ${libdir}/bonobo-2.0/samples/.debug ${libdir}/orbit-2.0/.debug"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/* ${libdir}/bonobo/monikers/* \
+ ${libdir}/bonobo-2.0/samples"
+
+LEAD_SONAME = "libbonobo-2.so"
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+ install -d ${D}${datadir}/idl/bonobo-activation-2.0/
+ install idl/*.idl ${D}${datadir}/idl/bonobo-activation-2.0/
+}
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo/configure-gthread.patch b/meta-gnome/recipes-gnome/bonobo/libbonobo/configure-gthread.patch
new file mode 100644
index 0000000000..005fa6760a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo/configure-gthread.patch
@@ -0,0 +1,11 @@
+--- libbonobo-2.14.0/configure.in.orig 2006-09-04 09:21:54.000000000 +0100
++++ libbonobo-2.14.0/configure.in 2006-09-04 09:22:58.000000000 +0100
+@@ -166,7 +166,7 @@
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(
+ [No working gthread-2.0 support found, using --disable-threads IS DISCOURAGED])
+- ]
++ ],[AC_MSG_RESULT(yes)]
+ )
+ CFLAGS=$libbonobo_save_CFLAGS
+ LIBS=$libbonobo_save_LIBS
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonobo_2.24.3.bb b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.24.3.bb
new file mode 100644
index 0000000000..c878286cef
--- /dev/null
+++ b/meta-gnome/recipes-gnome/bonobo/libbonobo_2.24.3.bb
@@ -0,0 +1,3 @@
+require libbonobo.inc
+SRC_URI[archive.md5sum] = "b217cef6a187505290c66c5bf8225d38"
+SRC_URI[archive.sha256sum] = "5310957fa90691689c0557218b8833f681666cae160bd84e1f2c2705189a4ebe"