aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2013-04-15 08:01:55 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-19 02:45:27 +0200
commitc9d4c9ff598b3ab9b16da5b53b2e12724af902c3 (patch)
tree4fc40ac2228f7431a2987d14b99c6ca507006e52 /meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb
parenta7b4558ff2cfa22796c10fda45c9d6c613bd1717 (diff)
downloadmeta-openembedded-contrib-c9d4c9ff598b3ab9b16da5b53b2e12724af902c3.tar.gz
metacity 2.24.13: fix crash on startup
Metacity crashes without the schemas installed, so RDEPEND on them root@beaglebone:~# metacity (metacity:594): GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.wm.preferences' is not installed Trace/breakpoint trap 6 XSELINUXs still allocated at reset SCREEN: 0 objects of 180 bytes = 0 total bytes 0 private allocs COLORMAP: 0 objects of 4 bytes = 0 total bytes 0 private allocs DEVICE: 0 objects of 64 bytes = 0 total bytes 0 private allocs CLIENT: 0 objects of 84 bytes = 0 total bytes 0 private allocs WINDOW: 0 objects of 20 bytes = 0 total bytes 0 private allocs PIXMAP: 2 objects of 8 bytes = 16 total bytes 0 private allocs GC: 4 objects of 8 bytes = 32 total bytes 0 private allocs CURSOR: 0 objects of 4 bytes = 0 total bytes 0 private allocs DBE_WINDOW: 0 objects of 12 bytes = 0 total bytes 0 private allocs TOTAL: 6 objects, 48 bytes, 0 allocs 2 PIXMAPs still all[ 281.248271] tilcdc 4830e000.fb: timeout waiting for framedone ocated at reset PIXMAP: 2 objects of 8 bytes = 16 total bytes 0 private allocs GC: 4 objects of 8 bytes = 32 total bytes 0 private allocs CURSOR: 0 objects of 4 bytes = 0 total bytes 0 private allocs DBE_WINDOW: 0 objects of 12 bytes = 0 total bytes 0 private allocs TOTAL: 6 objects, 48 bytes, 0 allocs 4 GCs still allocated at reset GC: 4 objects of 8 bytes = 32 total bytes 0 private allocs CURSOR: 0 objects of 4 bytes = 0 total bytes 0 private allocs DBE_WINDOW: 0 objects of 12 bytes = 0 total bytes 0 private allocs TOTAL: 4 objects, 32 bytes, 0 allocs root@beaglebone:~# Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb')
-rw-r--r--meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb b/meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb
index 23e5dda0b4..e14394a7f5 100644
--- a/meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb
+++ b/meta-gnome/recipes-gnome/metacity/metacity_2.34.13.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://src/include/main.h;endline=24;md5=c2242df552c880280315989bab626b90"
DEPENDS = "gsettings-desktop-schemas startup-notification gtk+ gconf gdk-pixbuf-native libcanberra gnome-doc-utils"
-PR = "r0"
+PR = "r1"
inherit gnome update-alternatives
@@ -27,4 +27,5 @@ do_configure_prepend() {
}
FILES_${PN} += "${datadir}/themes ${datadir}/gnome-control-center ${datadir}/gnome"
+RDEPENDS_${PN} += "gsettings-desktop-schemas"