aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/nautilus
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-10 10:13:24 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-10 10:13:24 +0200
commitb038ad87179391284e0829b6f92b463ba961f1e1 (patch)
tree141f3835739c38e82766923e518c43b070b21d8e /meta-gnome/recipes-gnome/nautilus
parent69fd0f67c4de99d01b643e32858565d40eaab803 (diff)
downloadmeta-openembedded-contrib-b038ad87179391284e0829b6f92b463ba961f1e1.tar.gz
nautilus: add 2.32.2
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/nautilus')
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch7
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff28
-rw-r--r--meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb39
3 files changed, 74 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch b/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch
new file mode 100644
index 0000000000..0062cfb11a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus/idl-sysroot.patch
@@ -0,0 +1,7 @@
+Index: nautilus-2.24.2/add-include-prefix
+===================================================================
+--- nautilus-2.24.2.orig/add-include-prefix 2008-10-06 17:22:21.000000000 +0000
++++ nautilus-2.24.2/add-include-prefix 2009-04-09 16:00:05.000000000 +0000
+@@ -1 +1 @@
+-sed -e 's/^/ /' -e 's/ */ /g' -e 's/ / -I /g' -e 's/ -I $//'
++sed -e 's:^: :' -e 's: *: :g' -e 's: : -I '"$SYSROOT"':g' -e 's: -I '"$SYSROOT"'$::'
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff b/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff
new file mode 100644
index 0000000000..ccd2934b3a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus/no-try-run-strftime.diff
@@ -0,0 +1,28 @@
+--- /tmp/configure.in 2009-04-13 11:26:43.000000000 +0200
++++ nautilus-2.26.1/configure.in 2009-04-13 11:28:37.000000000 +0200
+@@ -375,25 +375,6 @@
+
+ dnl ===========================================================================
+
+-dnl strftime checks
+-
+-AC_TRY_RUN([#include <time.h>
+- int main ()
+- {
+- char buf[100];
+- struct tm tm = {0};
+- tm.tm_year = 99;
+- if (strftime(buf, 100, "%EY", &tm) == 4 &&
+- strcmp (buf, "1999")==0)
+- return 0;
+- return 1;
+- }
+- ],
+- AC_DEFINE(HAVE_STRFTIME_EXTENSION, 1, [Define if strftime supports %E and %O modifiers.])
+- )
+-
+-dnl ===========================================================================
+-
+ #
+ # Checks for Xft/XRender
+ #
diff --git a/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb
new file mode 100644
index 0000000000..4cd3c690e4
--- /dev/null
+++ b/meta-gnome/recipes-gnome/nautilus/nautilus_2.32.2.bb
@@ -0,0 +1,39 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+LICENSE="GPLv2 && LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=7c0048536e43642a1f3a724c2909872b \
+ file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
+
+DEPENDS = "libunique gvfs librsvg libexif esound gnome-desktop orbit2-native"
+# optional: tracker
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "51565aa10d1625dff56e381228346911"
+SRC_URI[archive.sha256sum] = "2d4ff28c7a7aa5d40eb2468149954a564c257a305183773057584d22d15347a2"
+
+SRC_URI += "file://idl-sysroot.patch \
+ file://no-try-run-strftime.diff \
+"
+
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+do_configure() {
+ sed -i -e /docs/d Makefile.am
+ autotools_do_configure
+ # We need native orbit-idl with target idl files. No way to say it in a clean way:
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+PACKAGES += " libnautilus"
+
+RDEPENDS_${PN} = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+