aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-03 12:31:06 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-03 16:12:23 +0200
commited840de6e59dbf90d14c449c73d32f383446402b (patch)
tree42d175c419baf3cffdfcf0b7d21b1ca478e41f18 /meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
parent4791fb851eb96d5785616b1793d4e6367aa52ad9 (diff)
downloadmeta-openembedded-contrib-ed840de6e59dbf90d14c449c73d32f383446402b.tar.gz
orbit2: update to 2.14.17 to fix build with glib 2.36
license change of FSF address only Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
new file mode 100644
index 0000000000..74b6c122c8
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "CORBA ORB"
+SECTION = "x11/gnome/libs"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SRC_NAME = "ORBit2"
+SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
+SRC_URI = " \
+ ${GNOME_MIRROR}/${SRC_NAME}/${SHRT_VER}/${SRC_NAME}-${PV}.tar.bz2 \
+ file://configure-lossage.patch \
+ file://pkgconfig-fix.patch \
+ file://0001-linc2-src-Makefile.am-fix-build-with-glib-2.36.patch \
+"
+SRC_URI[md5sum] = "7082d317a9573ab338302243082d10d1"
+SRC_URI[sha256sum] = "55c900a905482992730f575f3eef34d50bda717c197c97c08fa5a6eafd857550"
+
+BBCLASSEXTEND = "native"
+
+IDL_COMPILER_DEPENDS = "orbit2-native"
+IDL_COMPILER_DEPENDS_virtclass-native = " "
+DEPENDS = "libidl popt ${IDL_COMPILER_DEPENDS}"
+
+# IDL_COMPILER_DEPENDS_virtclass-native for some reason didn't work and orbit2-native
+# was still in orbit2-native DEPENDS causing circular dependency
+DEPENDS_virtclass-native = "libidl-native popt-native"
+PARALLEL_MAKE = ""
+
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/*.la"
+FILES_${PN}-staticdev += "${libdir}/orbit-2.0/*.a"
+FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
+
+S = "${WORKDIR}/${SRC_NAME}-${PV}"
+
+LEAD_SONAME = "libORBit-2.so"
+
+inherit autotools pkgconfig gtk-doc
+
+EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
+EXTRA_OEMAKE_virtclass-native = " "