aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-12-12 13:36:42 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:23:45 -0800
commit30998bfc32e6ff2ac4adc183dde4aaaa080b6f02 (patch)
tree43bb6edf5a832993c7c32c44d9b0f5028e394cb9 /meta-gnome
parent2a6cfdd2d167696dd8f62893fbb89984498432b5 (diff)
downloadmeta-openembedded-contrib-30998bfc32e6ff2ac4adc183dde4aaaa080b6f02.tar.gz
libgnome: Fix invalid UTF-8 in header
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnome/05_fix_invalid_utf8.patch26
-rw-r--r--meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb4
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome/05_fix_invalid_utf8.patch b/meta-gnome/recipes-gnome/libgnome/libgnome/05_fix_invalid_utf8.patch
new file mode 100644
index 0000000000..cd90b8ed98
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgnome/libgnome/05_fix_invalid_utf8.patch
@@ -0,0 +1,26 @@
+From 33313713c4f5c1de500859ff128d6fd7e3af5722 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Mon, 7 Aug 2017 12:57:43 -0400
+Subject: gnome-config.h: Fix invalid UTF-8 in header
+
+This breaks the new Python `glib-mkenums`.
+---
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ libgnome/gnome-config.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgnome/gnome-config.h b/libgnome/gnome-config.h
+index 0c3dfe6..b9d659d 100644
+--- a/libgnome/gnome-config.h
++++ b/libgnome/gnome-config.h
+@@ -270,7 +270,7 @@ void gnome_config_clean_key_ (const char *path, gboolean priv);
+ #define gnome_config_private_clean_key(path) \
+ (gnome_config_clean_key_((path),TRUE))
+
+-/* returns the true filename of the config file */
++/* returns the true filename of the config file */
+ #define gnome_config_get_real_path(path) \
+ (g_build_filename (gnome_user_dir_get(),(path),NULL))
+ #define gnome_config_private_get_real_path(path) \
diff --git a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
index 0055ba4a3a..94fcf2e8c5 100644
--- a/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
+++ b/meta-gnome/recipes-gnome/libgnome/libgnome_2.32.1.bb
@@ -9,7 +9,9 @@ PR = "r2"
SRC_URI[archive.md5sum] = "a4345e6087ae6195d65a4674ffdca559"
SRC_URI[archive.sha256sum] = "b2c63916866485793b87398266dd7778548c1734923c272a94d84ee011b6f7a4"
-SRC_URI += "file://0001-libgnome-Makefile.am-allow-deprecated-symbols.patch"
+SRC_URI += "file://0001-libgnome-Makefile.am-allow-deprecated-symbols.patch \
+ file://05_fix_invalid_utf8.patch \
+"
GNOME_COMPRESS_TYPE="bz2"
DEPENDS += "libcanberra gconf-native gnome-vfs libbonobo esound intltool-native gnome-common-native"