aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-09-26 23:58:54 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:25 +0200
commitb3bcdd59e20163cc03b4bf814a84b798d0be9b96 (patch)
treeb616436cd085c626e0b6accfd3ce5daa5b5427c0 /meta-multimedia
parent4abf170d3601ed51aa1c04403c5aeccd9eaf27c9 (diff)
downloadmeta-openembedded-contrib-b3bcdd59e20163cc03b4bf814a84b798d0be9b96.tar.gz
schroedinger: add recipe
Originally based on the recipe from OE-Classic. Changes from that version: * Remove packaging of gstreamer plugin that was removed in 1.09 * Inherit pkgconfig since pkg-config is being used * Set more appropriate LICENSE * Add LIC_FILES_CHKSUM * Add SUMMARY * Optimise out inc file since it doesn't seem particularly useful to have one for this recipe Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/schroedinger/files/configure.ac.patch20
-rw-r--r--meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb22
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/schroedinger/files/configure.ac.patch b/meta-multimedia/recipes-multimedia/schroedinger/files/configure.ac.patch
new file mode 100644
index 0000000000..2ed8d22c6b
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/schroedinger/files/configure.ac.patch
@@ -0,0 +1,20 @@
+Use the version of orcc in the sysroot not the one from the host
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+Index: schroedinger-1.0.9/configure.ac
+===================================================================
+--- schroedinger-1.0.9.orig/configure.ac
++++ schroedinger-1.0.9/configure.ac
+@@ -54,7 +54,7 @@ if test "x${HAVE_ORC}" != xyes ; then
+ AC_ERROR([orc-0.4 >= $ORC_VER is required])
+ fi
+ SCHRO_PKG_DEPS="$SCHRO_PKG_DEPS orc-0.4 >= $ORC_VER"
+-ORCC=`$PKG_CONFIG --variable=orcc orc-0.4`
++ORCC=$STAGING_DIR`$PKG_CONFIG --variable=orcc orc-0.4`
+ AC_SUBST(ORCC)
+
+ AC_ARG_WITH([thread],
diff --git a/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb b/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb
new file mode 100644
index 0000000000..c338903f1e
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/schroedinger/schroedinger_1.0.11.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Dirac compressed video encoder/decoder"
+HOMEPAGE = "http://schrodinger.sourceforge.net/"
+LICENSE = "MPL-1.1 | GPLv2 | LGPLv2 | MIT"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d91a46405fc074b88c963cc4f2a0aae9 \
+ file://COPYING.GPL;md5=e181e3b7c66f5f96921d813c1074f833 \
+ file://COPYING.LGPL;md5=38c893e21baec4cd75ad800ba9e2410a \
+ file://COPYING.MIT;md5=8b345371b3536b4ce37ead1eafc88221 \
+ file://COPYING.MPL;md5=0117647fecb9a932c25a7bbfc0333c37"
+
+DEPENDS = "liboil orc-native orc"
+
+SRC_URI = "http://www.diracvideo.org/download/schroedinger/${BP}.tar.gz \
+ file://configure.ac.patch"
+
+SRC_URI[md5sum] = "da6af08e564ca1157348fb8d92efc891"
+SRC_URI[sha256sum] = "1e572a0735b92aca5746c4528f9bebd35aa0ccf8619b22fa2756137a8cc9f912"
+
+EXTRA_OECONF += "STAGING_DIR=${STAGING_DIR_NATIVE}"
+
+inherit autotools pkgconfig
+