aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-02-25 21:39:57 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-18 20:08:43 +0100
commitd92c9c652c272aa22036458adf3c0bcb44eca728 (patch)
tree12fe5d8b60a5c55834ef2e29daa3e0c4316eb8bf /meta-multimedia
parent8f151cf20f8b85ee5b6b2336f4c2151fcdf3b7fe (diff)
downloadmeta-openembedded-contrib-d92c9c652c272aa22036458adf3c0bcb44eca728.tar.gz
vlc: update to 2.1.2
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc70
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch53
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0001-enable-subdir-objects.patch13
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0002-fix-build-with-newer-freetype.patch16
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0002-glibc-does-not-provide-strlcpy.patch17
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0003-fix-build-with-newer-flac-1.3.0.patch21
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb19
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc_2.1.2.bb11
8 files changed, 74 insertions, 146 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 6400719f85..1b2490b720 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -1,49 +1,20 @@
DESCRIPTION = "Video player and streamer - davinci edition"
HOMEPAGE = "http://www.videolan.org"
-LICENSE = "GPLv2"
SECTION = "multimedia"
-DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac libxpm fluidsynth alsa-lib"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRC_URI = "http://download.videolan.org/pub/videolan/vlc/${PV}/vlc-${PV}.tar.bz2"
+DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl qt4-x11-free \
+ dbus libxml2 gnutls tremor faad2 ffmpeg flac libxpm fluidsynth alsa-lib \
+ libdvdcss libdvdread lua-native lua"
+
+SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
inherit autotools gettext
ARM_INSTRUCTION_SET = "arm"
-DEPENDS += "libdvdcss libdvdread lua5.1-native lua5.1"
-
-LEAD_SONAME = "libvlc.so.5"
-
-PACKAGES =+ "libvlc-dbg libvlc-dev libvlc"
-
-FILES_libvlc-dev = "${libdir}/lib*.so"
-
-FILES_libvlc-dbg = "\
- ${libdir}/.debug \
- ${libdir}/vlc/meta_engine/.debug \
- ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
- ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
- ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
- ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
- ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
- ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
- ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
- ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
- ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
- ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
-"
-
-FILES_libvlc = "${libdir}/lib*.so.*"
-
-FILES_${PN} += "${bindir}/vlc \
- ${datadir}/applications \
- ${datadir}/vlc/ \
- ${datadir}/icons \
-"
-
-FILES_${PN}-dbg += "${libdir}/vlc/*/.debug ${libdir}/vlc/plugins/*/.debug"
-
EXTRA_OECONF = "\
--enable-dvdread \
--with-contrib \
@@ -71,6 +42,7 @@ PACKAGECONFIG[id3tag] = "--enable-id3tag,--disable-id3tag,libid3tag"
PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52"
PACKAGECONFIG[mpeg2dec] = "--enable-mpeg2dec,--disable-mpeg2dec,mpeg2dec"
PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
+PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555"
do_configure() {
cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
@@ -81,6 +53,30 @@ do_configure() {
cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
oe_runconf
rm config.log
- sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
+ #sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g ${S}/vlc-config
sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
+ sed -i -e s:'${top_builddir_slash}libtool':${TARGET_SYS}-libtool:g ${S}/doltlibtool
}
+
+# This recipe packages vlc as a library as well, so qt4 dependencies
+# can be avoided when only the library is installed.
+PACKAGES =+ "libvlc"
+
+LEAD_SONAME_libvlc = "libvlc.so.5"
+FILES_libvlc = "${libdir}/lib*.so.*"
+
+FILES_${PN} += "\
+ ${bindir}/vlc \
+ ${datadir}/applications \
+ ${datadir}/vlc/ \
+ ${datadir}/icons \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/vlc/*/.debug \
+ ${libdir}/vlc/plugins/*/.debug \
+"
+
+FILES_${PN}-staticdev += "\
+ ${libdir}/vlc/plugins/*/*.a \
+"
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch
deleted file mode 100644
index 81233bffeb..0000000000
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 4da99e58bd1b06267793ef728a368e4032789376 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
-Date: Sat, 1 Oct 2011 22:58:21 +0300
-Subject: [PATCH] V4L2: mark horizontal and vertical center controls obsolete
-
-Upstream-Status: Backport
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-They were deprecated in Linux version 2.6.26.
----
- modules/access/v4l2/controls.c | 2 --
- modules/access/v4l2/video.c | 12 ++----------
- 2 files changed, 2 insertions(+), 12 deletions(-)
-
-diff -uNr vlc-1.1.11.orig/modules/access/v4l2.c vlc-1.1.11/modules/access/v4l2.c
---- vlc-1.1.11.orig/modules/access/v4l2.c 2011-06-03 19:59:40.000000000 +0200
-+++ vlc-1.1.11/modules/access/v4l2.c 2014-02-01 07:38:28.905142516 +0100
-@@ -159,12 +159,6 @@
- #define VFLIP_TEXT N_( "Vertical flip" )
- #define VFLIP_LONGTEXT N_( \
- "Flip the video vertically (if supported by the v4l2 driver)." )
--#define HCENTER_TEXT N_( "Horizontal centering" )
--#define HCENTER_LONGTEXT N_( \
-- "Set the camera's horizontal centering (if supported by the v4l2 driver)." )
--#define VCENTER_TEXT N_( "Vertical centering" )
--#define VCENTER_LONGTEXT N_( \
-- "Set the camera's vertical centering (if supported by the v4l2 driver)." )
-
- #define AUDIO_VOLUME_TEXT N_( "Volume" )
- #define AUDIO_VOLUME_LONGTEXT N_( \
-@@ -351,10 +345,8 @@
- HFLIP_LONGTEXT, true )
- add_integer( CFG_PREFIX "vflip", -1, NULL, VFLIP_TEXT,
- VFLIP_LONGTEXT, true )
-- add_integer( CFG_PREFIX "hcenter", -1, NULL, HCENTER_TEXT,
-- HCENTER_LONGTEXT, true )
-- add_integer( CFG_PREFIX "vcenter", -1, NULL, VCENTER_TEXT,
-- VCENTER_LONGTEXT, true )
-+ add_obsolete_integer( CFG_PREFIX "hcenter" ) /* since Linux 2.6.26 */
-+ add_obsolete_integer( CFG_PREFIX "vcenter" ) /* since Linux 2.6.26 */
- add_integer( CFG_PREFIX "audio-volume", -1, NULL, AUDIO_VOLUME_TEXT,
- AUDIO_VOLUME_LONGTEXT, true )
- add_integer( CFG_PREFIX "audio-balance", -1, NULL, AUDIO_BALANCE_TEXT,
-@@ -518,8 +510,6 @@
- { "gain", V4L2_CID_GAIN },
- { "hflip", V4L2_CID_HFLIP },
- { "vflip", V4L2_CID_VFLIP },
-- { "hcenter", V4L2_CID_HCENTER },
-- { "vcenter", V4L2_CID_VCENTER },
- { NULL, 0 }
- };
-
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-enable-subdir-objects.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-enable-subdir-objects.patch
new file mode 100644
index 0000000000..9f0e708ed7
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-enable-subdir-objects.patch
@@ -0,0 +1,13 @@
+Index: vlc-2.1.2/configure.ac
+===================================================================
+--- vlc-2.1.2.orig/configure.ac
++++ vlc-2.1.2/configure.ac
+@@ -24,7 +24,7 @@ AC_CANONICAL_BUILD
+ AC_CANONICAL_HOST
+ AC_PRESERVE_HELP_ORDER
+
+-AM_INIT_AUTOMAKE(tar-ustar color-tests foreign)
++AM_INIT_AUTOMAKE(tar-ustar color-tests foreign subdir-objects)
+ AC_CONFIG_HEADERS([config.h])
+
+ # Disable with "./configure --disable-silent-rules" or "make V=1"
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0002-fix-build-with-newer-freetype.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0002-fix-build-with-newer-freetype.patch
deleted file mode 100644
index 100ba9724e..0000000000
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0002-fix-build-with-newer-freetype.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Upstream-Status: Pending
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-diff -uNr vlc-1.1.11.orig/modules/misc/freetype.c vlc-1.1.11/modules/misc/freetype.c
---- vlc-1.1.11.orig/modules/misc/freetype.c 2011-07-09 17:18:51.000000000 +0200
-+++ vlc-1.1.11/modules/misc/freetype.c 2014-02-01 07:45:32.078131862 +0100
-@@ -60,7 +60,7 @@
- #endif
-
- /* Freetype */
--#include <freetype/ftsynth.h>
-+#include <freetype2/ftsynth.h>
- #include FT_FREETYPE_H
- #include FT_GLYPH_H
- #define FT_FLOOR(X) ((X & -64) >> 6)
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0002-glibc-does-not-provide-strlcpy.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0002-glibc-does-not-provide-strlcpy.patch
new file mode 100644
index 0000000000..6d2a46fb3c
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0002-glibc-does-not-provide-strlcpy.patch
@@ -0,0 +1,17 @@
+Index: vlc-2.1.2/src/input/subtitles.c
+===================================================================
+--- vlc-2.1.2.orig/src/input/subtitles.c
++++ vlc-2.1.2/src/input/subtitles.c
+@@ -44,6 +44,12 @@
+ #include "input_internal.h"
+
+ /**
++ * Drepper's alternative
++ * http://en.wikibooks.org/wiki/C_Programming/C_Reference/nonstandard/strlcpy
++ */
++#define strlcpy(dst, src, n) *((char* ) mempcpy(dst, src, n)) = '\0'
++
++/**
+ * We are not going to autodetect more subtitle files than this.
+ */
+ #define MAX_SUBTITLE_FILES 128
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0003-fix-build-with-newer-flac-1.3.0.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0003-fix-build-with-newer-flac-1.3.0.patch
deleted file mode 100644
index 8278a3e936..0000000000
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0003-fix-build-with-newer-flac-1.3.0.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-flac-1.3.0 removed FLAC from pkg-config's includedir, so the user of flac.pc is supposed to
-include the headers with FLAC/ prefix now.
-
-Upstream-Status: Pending
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-diff -uNr vlc-1.1.11.orig/modules/codec/flac.c vlc-1.1.11/modules/codec/flac.c
---- vlc-1.1.11.orig/modules/codec/flac.c 2014-02-23 01:29:56.337515018 +0000
-+++ vlc-1.1.11/modules/codec/flac.c 2014-02-23 01:29:04.477514993 +0000
-@@ -38,8 +38,8 @@
- #include <vlc_codec.h>
- #include <vlc_aout.h>
-
--#include <stream_decoder.h>
--#include <stream_encoder.h>
-+#include <FLAC/stream_decoder.h>
-+#include <FLAC/stream_encoder.h>
-
- #include <vlc_block_helper.h>
- #include <vlc_bits.h>
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb
deleted file mode 100644
index 368db591a7..0000000000
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_1.1.11.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-# This recipe packages vlc as a library as well, so qt4 dependencies
-# can be avoided when only the library is installed.
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=ed7e492ee44e70125a5d42e118354a13"
-
-require vlc.inc
-
-SRC_URI += "file://0001-V4L2-mark-horizontal-and-vertical-center-controls-ob.patch"
-SRC_URI += "file://0002-fix-build-with-newer-freetype.patch"
-SRC_URI += "file://0003-fix-build-with-newer-flac-1.3.0.patch"
-
-PR = "r4"
-
-# work around build failure
-EXTRA_OECONF += " --enable-libxml2=no"
-
-SRC_URI[md5sum] = "a64846d6f21ea179ae8e8bfb6f9447fe"
-SRC_URI[sha256sum] = "682560be08b82bedfaf30d8a611d80093c5883c1de72fcbcf05715b8e9f4e1cb"
-
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.2.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.2.bb
new file mode 100644
index 0000000000..9dc2b10e84
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_2.1.2.bb
@@ -0,0 +1,11 @@
+require ${BPN}.inc
+
+# work around build failure
+EXTRA_OECONF += " --enable-libxml2=no"
+
+SRC_URI += "file://0001-enable-subdir-objects.patch \
+ file://0002-glibc-does-not-provide-strlcpy.patch \
+"
+
+SRC_URI[md5sum] = "fb6787ad749aadcfaeab3471939b3426"
+SRC_URI[sha256sum] = "219b812be1bc2eba40faa86419d0aa2c479a7380af8af216e8bfa22eb6fc8ec4"