aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-10-29 01:23:26 -0400
committerJoe MacDonald <joe_macdonald@mentor.com>2014-11-04 16:02:44 -0500
commit34ca3aeef1a8ff74de548c427fff8dc94f4b720a (patch)
tree0502dac46a90509fa291999152355eb5ecd0d5c0 /meta-networking/recipes-connectivity
parent22119569b940a9294f37bdb36a84082faa281c1a (diff)
downloadmeta-openembedded-contrib-34ca3aeef1a8ff74de548c427fff8dc94f4b720a.tar.gz
vpnc: use nativeperl to run perl scripts
inhert perlnative and make sure we use nativeperl to run perl scripts when compile. fixed: | ./makeman.pl | Can't locate Fatal.pm in @INC Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
index 986416ade2..4efc412a04 100644
--- a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
+++ b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
@@ -7,9 +7,16 @@ LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://COPYING;md5=173b74cb8ac640a9992c03f3bce22a33"
DEPENDS = "libgcrypt"
+inherit perlnative
+
CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
LDFLAGS_append = " -lgcrypt -lgpg-error"
+do_configure_append () {
+ # Make sure we use our nativeperl wrapper
+ sed -i "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/*.pl
+}
+
do_install () {
sed -i s:m600:m\ 600:g Makefile
oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install