aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-connectivity
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/crda/crda_1.1.3.bb12
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb50
-rw-r--r--meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb8
3 files changed, 35 insertions, 35 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
index d736c7a2de..dc1fc21cf1 100644
--- a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
+++ b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb
@@ -9,7 +9,7 @@ DEPENDS = "python-m2crypto-native python-native libgcrypt libnl"
SRC_URI = "http://wireless.kernel.org/download/crda/${P}.tar.bz2;name=crda \
http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \
- "
+"
SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c"
SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0"
SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b"
@@ -20,19 +20,19 @@ inherit python-dir pythonnative
EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}"
do_compile() {
- oe_runmake all_noverify
+ oe_runmake all_noverify
}
do_install() {
- oe_runmake install
+ oe_runmake install
- install -d ${D}${libdir}/crda/
+ install -d ${D}${libdir}/crda/
- install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin
+ install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin
}
RDEPENDS_${PN} = "udev"
FILES_${PN} += "${libdir}crda/regulatory.bin \
${base_libdir}/udev/rules.d/85-regulatory.rules \
- "
+"
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
index 155befec1b..603bf01762 100644
--- a/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils_1.9.1.bb
@@ -25,40 +25,40 @@ inherit autotools gettext
noipv6="${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6 gl_cv_socket_ipv6=no', d)}"
EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \
- --with-path-procnet-dev=/proc/net/dev \
- ${noipv6} \
- "
+ --with-path-procnet-dev=/proc/net/dev \
+ ${noipv6} \
+"
do_configure_prepend () {
- export HELP2MAN='true'
- cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
- rm -f ${S}/glob/configure*
+ export HELP2MAN='true'
+ cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath
+ rm -f ${S}/glob/configure*
}
do_install () {
- autotools_do_install
- install -d ${D}${base_sbindir} ${D}${base_bindir}
- mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${BPN}
- mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${BPN}
- mv ${D}${bindir}/logger ${D}${bindir}/logger.${BPN}
- mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${BPN}
- mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${BPN}
- mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${BPN}
+ autotools_do_install
+ install -d ${D}${base_sbindir} ${D}${base_bindir}
+ mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${BPN}
+ mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${BPN}
+ mv ${D}${bindir}/logger ${D}${bindir}/logger.${BPN}
+ mv ${D}${bindir}/traceroute ${D}${bindir}/traceroute.${BPN}
+ mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${BPN}
+ mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ifconfig.${BPN}
}
pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/tftp tftp tftp.${BPN} 100
- update-alternatives --install ${bindir}/telnet telnet telnet.${BPN} 100
- update-alternatives --install ${bindir}/logger logger logger.${BPN} 100
- update-alternatives --install ${bindir}/traceroute traceroute traceroute.${BPN} 100
- update-alternatives --install ${base_bindir}/hostname hostname hostname.${BPN} 100
- update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${BPN} 100
+ update-alternatives --install ${bindir}/tftp tftp tftp.${BPN} 100
+ update-alternatives --install ${bindir}/telnet telnet telnet.${BPN} 100
+ update-alternatives --install ${bindir}/logger logger logger.${BPN} 100
+ update-alternatives --install ${bindir}/traceroute traceroute traceroute.${BPN} 100
+ update-alternatives --install ${base_bindir}/hostname hostname hostname.${BPN} 100
+ update-alternatives --install ${base_sbindir}/ifconfig ifconfig ifconfig.${BPN} 100
}
pkg_prerm_${PN} () {
- update-alternatives --remove tftp tftp.${BPN}
- update-alternatives --remove telnet telnet.${BPN}
- update-alternatives --remove logger logger.${BPN}
- update-alternatives --remove traceroute traceroute.${BPN}
- update-alternatives --remove ifconfig ifconfig.${BPN}
+ update-alternatives --remove tftp tftp.${BPN}
+ update-alternatives --remove telnet telnet.${BPN}
+ update-alternatives --remove logger logger.${BPN}
+ update-alternatives --remove traceroute traceroute.${BPN}
+ update-alternatives --remove ifconfig ifconfig.${BPN}
}
diff --git a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
index 1b2b8bf66d..2ce9530d03 100644
--- a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
+++ b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
@@ -12,10 +12,10 @@ CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
LDFLAGS_append = " -lgcrypt -lgpg-error"
do_install () {
- sed -i s:m600:m\ 600:g Makefile
- oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
- rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
- install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
+ sed -i s:m600:m\ 600:g Makefile
+ oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install
+ rm -f ${D}${sysconfdir}/vpnc/vpnc.conf #This file is useless
+ install ${WORKDIR}/default.conf ${D}${sysconfdir}/vpnc/default.conf
}
CONFFILES_${PN} = "${sysconfdir}/vpnc/default.conf"