aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-12 12:42:03 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commit748aea615e1d15098a70ecbcaa898f43046cc8e6 (patch)
treee40c7ab640125b2aa4d20011ff44fd7082adefae /meta-networking/recipes-connectivity
parentd87fb0d30c441714a4cfe8faaf389c25d0cb7f6d (diff)
downloadmeta-openembedded-contrib-748aea615e1d15098a70ecbcaa898f43046cc8e6.tar.gz
dibbler: Update to latest
Drop upstreamed patch Fixed compatibility with g++-10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/dibbler/dibbler/0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch74
-rw-r--r--meta-networking/recipes-connectivity/dibbler/dibbler_git.bb3
2 files changed, 1 insertions, 76 deletions
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler/0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch b/meta-networking/recipes-connectivity/dibbler/dibbler/0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch
deleted file mode 100644
index 346a56a9ad..0000000000
--- a/meta-networking/recipes-connectivity/dibbler/dibbler/0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 630086cf1b3fba71822319a268d3711734cd6aa8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 31 Jan 2019 12:56:13 -0800
-Subject: [PATCH] linux-port: Rename pthread_mutex_t variable 'lock'
-
-lock is also used by libc++ in std namespace and using it here causes
-clang to fail e.g.
-
-dibbler-client.cpp:47:25: error: reference to 'lock' is ambiguous
- pthread_mutex_lock(&lock);
- ^
-../../../../../../../workspace/sources/dibbler/Port-linux/dibbler-client.cpp:29:26: note: candidate found by name lookup is 'lock'
-extern ::pthread_mutex_t lock;
- ^
-/mnt/a/yoe/build/tmp/work/aarch64-yoe-linux/dibbler/1.0.1+1.0.2RC1+gitc4b0ed52e751da7823dd9a36e91f93a6310e5525-r0/recipe-sysroot/usr/include/c++/v1/mutex:446:1: note: candidate found by name lookup is 'std::__1::lock'
-lock(_L0& __l0, _L1& __l1, _L2& __l2, _L3& ...__l3)
-
-Upstream-Status: Submitted [https://github.com/tomaszmrugalski/dibbler/pull/37]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- Port-linux/dibbler-client.cpp | 6 +++---
- Port-linux/lowlevel-linux-link-state.c | 6 +++---
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/Port-linux/dibbler-client.cpp b/Port-linux/dibbler-client.cpp
-index 78f34241..b5ebb9f0 100644
---- a/Port-linux/dibbler-client.cpp
-+++ b/Port-linux/dibbler-client.cpp
-@@ -26,7 +26,7 @@ using namespace std;
-
- #define IF_RECONNECTED_DETECTED -1
-
--extern pthread_mutex_t lock;
-+extern pthread_mutex_t dibbler_lock;
-
- TDHCPClient* ptr = 0;
-
-@@ -44,8 +44,8 @@ void signal_handler(int n) {
- #ifdef MOD_CLNT_CONFIRM
- void signal_handler_of_linkstate_change(int n) {
- Log(Notice) << "Network switch off event detected. initiating CONFIRM." << LogEnd;
-- pthread_mutex_lock(&lock);
-- pthread_mutex_unlock(&lock);
-+ pthread_mutex_lock(&dibbler_lock);
-+ pthread_mutex_unlock(&dibbler_lock);
- }
- #endif
-
-diff --git a/Port-linux/lowlevel-linux-link-state.c b/Port-linux/lowlevel-linux-link-state.c
-index 76293ea1..e6b94063 100644
---- a/Port-linux/lowlevel-linux-link-state.c
-+++ b/Port-linux/lowlevel-linux-link-state.c
-@@ -34,7 +34,7 @@ volatile int * notifier = 0;
- int isDone = 0;
- pthread_t parent_id;
- pthread_t ntid;
--pthread_mutex_t lock;
-+pthread_mutex_t dibbler_lock;
-
- struct state {
- int id;
-@@ -86,9 +86,9 @@ void link_state_changed(int ifindex)
- {
- if (changed_links->cnt<16)
- changed_links->ifindex[changed_links->cnt++] = ifindex;
-- pthread_mutex_lock(&lock);
-+ pthread_mutex_lock(&dibbler_lock);
- *notifier = 1; /* notify that change has occured */
-- pthread_mutex_unlock(&lock);
-+ pthread_mutex_unlock(&dibbler_lock);
- pthread_kill(parent_id,SIGUSR1);
- } else
- {
diff --git a/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
index 90051a319a..c2f4827161 100644
--- a/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
+++ b/meta-networking/recipes-connectivity/dibbler/dibbler_git.bb
@@ -5,11 +5,10 @@ HOMEPAGE = "http://klub.com.pl/dhcpv6"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3"
-SRCREV = "c4b0ed52e751da7823dd9a36e91f93a6310e5525"
+SRCREV = "a7c6cf58a88a510cb00841351e75030ce78d36bf"
SRC_URI = "git://github.com/tomaszmrugalski/dibbler \
file://dibbler_fix_getSize_crash.patch \
- file://0001-linux-port-Rename-pthread_mutex_t-variable-lock.patch \
"
PV = "1.0.1+1.0.2RC1+git${SRCREV}"