aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/proftpd
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-12-05 17:03:44 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-12-05 14:13:21 -0500
commitc75fc2573b88576b577946ff834b10446e591532 (patch)
tree8483470849840153c7793187f4eb31b4eefe065e /meta-networking/recipes-daemons/proftpd
parent10cd81211f2054599728d5a4ce91e51b7cc853db (diff)
downloadmeta-openembedded-contrib-c75fc2573b88576b577946ff834b10446e591532.tar.gz
proftpd: fix do_install failure after libexecdir change
As of OE-Core commit id 406bd38b4232f9f399ef5ffe0b4fac72ed605a23 libexecdir has been changed to ${libdir}/${BPN}. As we are already deleting ${libdir}/proftpd which is the same as ${libdir}/${BPN} in this case, introduce a check to see if ${libexecdir} still exists before attempting to remove it possibly a second time. This will handle if libexecdir is set to its original value or a custom value in the distro config. Based on a patch by Kevin Strasser <kevin.strasser@linux.intel.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-networking/recipes-daemons/proftpd')
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
index 8624c16532..7279cfb67f 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.4b.bb
@@ -34,7 +34,8 @@ FTPGROUP = "ftp"
do_install () {
oe_runmake DESTDIR=${D} install
- rmdir ${D}${libexecdir} ${D}${libdir}/proftpd ${D}${datadir}/locale
+ rmdir ${D}${libdir}/proftpd ${D}${datadir}/locale
+ [ -d ${D}${libexecdir} ] && rmdir ${D}${libexecdir}
sed -i '/ *User[ \t]*/s/ftp/${FTPUSER}/' ${D}${sysconfdir}/proftpd.conf
sed -i '/ *Group[ \t]*/s/ftp/${FTPGROUP}/' ${D}${sysconfdir}/proftpd.conf
install -d ${D}${sysconfdir}/init.d