aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-28 15:54:04 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-04 00:28:31 +0200
commitfd7973168ab1c8f696cc5e8bcddfeac224cfc775 (patch)
treedbd96fb742333ec9ceece85e7e4cac7cb7701860 /meta-networking/recipes-daemons
parent66182220e8b1133af83f58e40d9d3fa3d358299a (diff)
downloadmeta-openembedded-contrib-fd7973168ab1c8f696cc5e8bcddfeac224cfc775.tar.gz
vsftpd: fix pkg_postinst
Fix pkg_postinst to not exit if "$D" is not empty. Otherwise, postinsts from update-rc.d.bbclass would not run and the symlinks under /etc/rc?.d/ would not be created. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
index a1c4ff4ad4..07c73c5f76 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
@@ -88,12 +88,11 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp
GROUPADD_PARAM_${PN} = "-r ftp"
pkg_postinst_${PN}() {
- if [ -n "$D" ]; then
- exit 0
- fi
+ if [ -z "$D" ]; then
if type systemd-tmpfiles >/dev/null; then
- systemd-tmpfiles --create
+ systemd-tmpfiles --create
elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
- ${sysconfdir}/init.d/populate-volatile.sh update
+ ${sysconfdir}/init.d/populate-volatile.sh update
fi
+ fi
}