aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-28 15:54:05 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-04 00:28:31 +0200
commit3efc0c1974fd5191d04a8d8d622016e137d24ca0 (patch)
tree643e60cf3f7d61657d4fb41a20b50c26411fad60 /meta-networking/recipes-daemons
parentfd7973168ab1c8f696cc5e8bcddfeac224cfc775 (diff)
downloadmeta-openembedded-contrib-3efc0c1974fd5191d04a8d8d622016e137d24ca0.tar.gz
vsftpd: add systemd service file
Add systemd service for vsftpd. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/files/vsftpd.service9
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb10
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/files/vsftpd.service b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.service
new file mode 100644
index 0000000000..e271020267
--- /dev/null
+++ b/meta-networking/recipes-daemons/vsftpd/files/vsftpd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Vsftpd ftp daemon
+After=network.target
+
+[Service]
+ExecStart=@SBINDIR@/vsftpd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
index 07c73c5f76..e4d65eea6f 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
@@ -16,6 +16,7 @@ SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
file://vsftpd.ftpusers \
file://change-secure_chroot_dir.patch \
file://volatiles.99_vsftpd \
+ file://vsftpd.service \
"
LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271 \
@@ -35,7 +36,7 @@ PAMLIB = "${@base_contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -l
NOPAM_SRC ="${@base_contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}"
SRC_URI += "${@base_contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)}"
-inherit update-rc.d useradd
+inherit update-rc.d useradd systemd
CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf"
LDFLAGS_append =" -lcrypt -lcap"
@@ -76,6 +77,11 @@ do_install() {
echo "d /var/run/vsftpd/empty 0755 root root -" \
> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
fi
+
+ # Install systemd unit files
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/vsftpd.service ${D}${systemd_unitdir}/system
+ sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/vsftpd.service
}
INITSCRIPT_PACKAGES = "${PN}"
@@ -87,6 +93,8 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp
--shell /bin/false ftp "
GROUPADD_PARAM_${PN} = "-r ftp"
+SYSTEMD_SERVICE_${PN} = "vsftpd.service"
+
pkg_postinst_${PN}() {
if [ -z "$D" ]; then
if type systemd-tmpfiles >/dev/null; then