aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2016-07-12 14:55:41 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:06:49 -0400
commit53794a7c57c338e8474a9c90d804723e3a3cb0d4 (patch)
treeaa4228981609584cc7729fd757ed7bbc63b9d566 /meta-networking/recipes-daemons
parent7e4f22517ada29f634970721481f0a7de1f3bffd (diff)
downloadmeta-openembedded-contrib-53794a7c57c338e8474a9c90d804723e3a3cb0d4.tar.gz
atftp: do not create user nobody
The recipe for atftp inherits useradd.bbclass and re-creates the user nobody as a "system" user. This is not correct and is in vain because this new definition will not be created on the target. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/atftp/atftp_git.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/atftp/atftp_git.bb b/meta-networking/recipes-daemons/atftp/atftp_git.bb
index 0ece58f7d3..0556fe2a0e 100644
--- a/meta-networking/recipes-daemons/atftp/atftp_git.bb
+++ b/meta-networking/recipes-daemons/atftp/atftp_git.bb
@@ -17,7 +17,7 @@ SRC_URI = "git://git.code.sf.net/p/atftp/code \
"
S = "${WORKDIR}/git"
-inherit autotools update-rc.d useradd systemd
+inherit autotools update-rc.d systemd
PACKAGECONFIG ??= "tcp-wrappers"
PACKAGECONFIG[pcre] = "--enable-libpcre,--disable-libpcre,libpcre"
@@ -28,9 +28,6 @@ INITSCRIPT_PACKAGES = "${PN}d"
INITSCRIPT_NAME_${PN}d = "atftpd"
INITSCRIPT_PARAMS_${PN}d = "defaults 80"
-USERADD_PACKAGES = "${PN}d"
-USERADD_PARAM_${PN}d = "--system --no-create-home --shell /bin/false \
- --user-group nobody"
EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -std=gnu89'"