aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2016-07-19 16:41:14 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:06:50 -0400
commit85d96d1ceab43f5646fb403e29756e83ee021963 (patch)
tree777376da25e83a98a1a4929fff285d96eaa8811a /meta-networking/recipes-daemons
parentf8dd8cde90c4d6c945177117953e7123e1401236 (diff)
downloadmeta-openembedded-contrib-85d96d1ceab43f5646fb403e29756e83ee021963.tar.gz
proftpd: fix PACKAGECONFIG settings
When using '??=' to set a variable, '+=' will cause the '??=' value to be discarded. We change how PACKAGECONFIG is defined. We also do not make sia support a default since it is not likely to be available. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
index 2a360831dc..c9dffeeb26 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
@@ -21,9 +21,10 @@ SRC_URI[sha256sum] = "a1f48df8539c414ec56e0cea63dcf4b8e16e606c05f10156f030a4a67f
inherit autotools-brokensep useradd update-rc.d systemd
-PACKAGECONFIG ??= "sia shadow"
-PACKAGECONFIG += " ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
-PACKAGECONFIG += " ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+PACKAGECONFIG ??= "shadow \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
+ "
PACKAGECONFIG[curses] = "--enable-curses --enable-ncurses, --disable-curses --disable-ncurses, ncurses"
PACKAGECONFIG[openssl] = "--enable-openssl, --disable-openssl, openssl, openssl"