aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorCatalin Enache <catalin.enache@windriver.com>2016-05-11 16:45:33 +0300
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-18 10:53:51 -0400
commit8fe7d1e60b2d64079a8f9c882231c2f27fc1729b (patch)
treecbd6fce71ccbb5065b6ec1925360bd6a7906ec4c /meta-networking/recipes-daemons
parent37297c3222a40b916d98ccd06b757b595aebc756 (diff)
downloadmeta-openembedded-contrib-8fe7d1e60b2d64079a8f9c882231c2f27fc1729b.tar.gz
proftpd: fix mod_tls build issue
Backported upstream commit: https://github.com/proftpd/proftpd/commit/253e6ef6a4fde5545111f7c439a9692afecc597b Signed-off-by: Catalin Enache <catalin.enache@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch64
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb1
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch b/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch
new file mode 100644
index 0000000000..3b9856054e
--- /dev/null
+++ b/meta-networking/recipes-daemons/proftpd/files/Fix-build-errors.patch
@@ -0,0 +1,64 @@
+From 253e6ef6a4fde5545111f7c439a9692afecc597b Mon Sep 17 00:00:00 2001
+From: TJ Saunders <tj@castaglia.org>
+Date: Thu, 10 Mar 2016 15:17:50 -0800
+Subject: [PATCH] Fix build errors; used wrong variable name, and pushed
+ without building. Shame.
+
+Upstream-Status: Backport
+
+Author: TJ Saunders <tj@castaglia.org>
+Signed-off-by: Catalin Enache <catalin.enache@windriver.com>
+---
+ contrib/mod_tls.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/contrib/mod_tls.c b/contrib/mod_tls.c
+index c557454..ecd9f56 100644
+--- a/contrib/mod_tls.c
++++ b/contrib/mod_tls.c
+@@ -2423,7 +2423,7 @@ static int tls_ctrl_renegotiate_cb(CALLBACK_FRAME) {
+ }
+ #endif
+
+-static DH *tls_dh_cb(SSL *ssl, int is_export, int keylength) {
++static DH *tls_dh_cb(SSL *ssl, int is_export, int keylen) {
+ DH *dh = NULL;
+ EVP_PKEY *pkey;
+ int pkeylen = 0, use_pkeylen = FALSE;
+@@ -2597,7 +2597,7 @@ static DH *tls_dh_cb(SSL *ssl, int is_export, int keylength) {
+ }
+
+ #ifdef PR_USE_OPENSSL_ECC
+-static EC_KEY *tls_ecdh_cb(SSL *ssl, int is_export, int keylength) {
++static EC_KEY *tls_ecdh_cb(SSL *ssl, int is_export, int keylen) {
+ static EC_KEY *ecdh = NULL;
+ static int init = 0;
+
+@@ -5064,7 +5064,7 @@ static ssize_t tls_read(SSL *ssl, void *buf, size_t len) {
+ return count;
+ }
+
+-static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylength) {
++static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylen) {
+ BIGNUM *e = NULL;
+
+ if (tls_tmp_rsa) {
+@@ -5082,13 +5082,13 @@ static RSA *tls_rsa_cb(SSL *ssl, int is_export, int keylength) {
+ return NULL;
+ }
+
+- if (RSA_generate_key_ex(tls_tmp_rsa, keylength, e, NULL) != 1) {
++ if (RSA_generate_key_ex(tls_tmp_rsa, keylen, e, NULL) != 1) {
+ BN_free(e);
+ return NULL;
+ }
+
+ #else
+- tls_tmp_rsa = RSA_generate_key(keylength, RSA_F4, NULL, NULL);
++ tls_tmp_rsa = RSA_generate_key(keylen, RSA_F4, NULL, NULL);
+ #endif /* OpenSSL version 0.9.8 and later */
+
+ if (e != NULL) {
+--
+2.7.4
+
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
index 57d4984bd9..2a360831dc 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
@@ -13,6 +13,7 @@ SRC_URI = "ftp://ftp.proftpd.org/distrib/source/${BPN}-${PV}.tar.gz \
file://build_fixup.patch \
file://proftpd.service \
file://CVE-2016-3125.patch \
+ file://Fix-build-errors.patch \
"
SRC_URI[md5sum] = "b9d3092411478415b31d435f8e26d173"