aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorDai Caiyun <daicy.fnst@cn.fujitsu.com>2016-04-28 13:30:08 +0300
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-16 21:26:12 -0400
commite86c7ef20f90813146a565e9e9f5912d9a6c7b42 (patch)
treee525004bab4d1f6af7e4bf1ff87af999bbffa4f9 /meta-networking/recipes-daemons
parent35326fa74dee53ffa4bd454e5fc95fdcbf0d5da6 (diff)
downloadmeta-openembedded-contrib-e86c7ef20f90813146a565e9e9f5912d9a6c7b42.tar.gz
opensaf: make sure /etc/init.d/opensafd exist
when disable sysvinit and specify "systemd" in DISTRO_FEATURES, the recipe "inhert systemd" will delete "/etc/init.d/opensafd",but "/etc/init.d/opensafd" is needed to start opensafd.service. Signed-off-by: Dai Caiyun <daicy.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
index f6873781d0..da9c105207 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.0.0.bb
@@ -55,9 +55,19 @@ do_install_append() {
install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
}
-FILES_${PN} += "${localstatedir}/run"
+FILES_${PN} += "${localstatedir}/run ${systemd_unitdir}/system/*.service"
FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
INSANE_SKIP_${PN} = "dev-so"
RDEPENDS_${PN} += "bash python"
+
+do_sysvinit_install() {
+ if [ ! -d "${D}${sysconfdir}/init.d" ]; then
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
+ fi
+}
+
+addtask sysvinit_install after do_install before do_package
+