aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-11 19:45:32 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-21 18:11:01 -0700
commit46af44ffe6a89dc9c6eccab0a7d60b377a3bb00f (patch)
tree488df92e1c79ead7d4ac3c9ccbbdd7365f51d591 /meta-networking/recipes-daemons
parentec749b810078e2f6804edc5d28d7abc581af8f26 (diff)
downloadmeta-openembedded-contrib-46af44ffe6a89dc9c6eccab0a7d60b377a3bb00f.tar.gz
ippool: Enable systemd service on install
Start the daemon with RPC support Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool/ippool.service4
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool_1.3.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/ippool/ippool/ippool.service b/meta-networking/recipes-daemons/ippool/ippool/ippool.service
index 281ae5fd19..f168e4ccb6 100644
--- a/meta-networking/recipes-daemons/ippool/ippool/ippool.service
+++ b/meta-networking/recipes-daemons/ippool/ippool/ippool.service
@@ -5,8 +5,8 @@ After=rpcbind.service
[Service]
Type=simple
-# Start ippoold in the foreground!
-ExecStart=@SBINDIR@/ippoold -f
+# Start ippoold in the foreground! and enable RPC
+ExecStart=@SBINDIR@/ippoold -R -f
# Normal output will go to syslog, so suppress stdout.
StandardOutput=null
# ExecStop is not needed. systemd will send SIGTERM
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
index f592912f9b..36ea289945 100644
--- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
+++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
@@ -50,8 +50,6 @@ EXTRA_OEMAKE += "IPPOOL_TEST=y"
CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
SYSTEMD_SERVICE:${PN} = "ippool.service"
-SYSTEMD_AUTO_ENABLE = "disable"
-
do_compile:prepend() {
# fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env