aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2016-09-26 01:31:34 +0530
committerJoe MacDonald <joe_macdonald@mentor.com>2016-10-20 11:16:55 -0400
commit93b0d657931c9ea7a6fc0df8ca9925a0fa7a80cc (patch)
tree6a9a3d499c46609625f48a2db583f4a4a2d0374f /meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb
parent9e8d127a800d1dbada68ba4cf5ba5cfd72be1675 (diff)
downloadmeta-openembedded-contrib-93b0d657931c9ea7a6fc0df8ca9925a0fa7a80cc.tar.gz
iscsitarget: resolve build error with linux kernel 4.8
The below changes in kernel source, triggered iscsitarget build fail with linux kernel v4.8. 1. An extra 'flags' argument has been passed to vfs_readv/vfs_writev syscalls in v4.8. So, set this argument to "0" for now (as there is no real need for that). Ref: https://github.com/torvalds/linux/commit/793b80ef14af56d20c998265287648ad34239b6f Solves: -- snip -- TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/nthread.c: In function 'write_data': TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/nthread.c:350:9: error: too few arguments to function 'vfs_writev' res = vfs_writev(file, (struct iovec __user *) iop, count, &off); ^~~~~~~~~~ -- snip -- 2. Redefine dropped PAGE_CACHE_* and page_cache_{get,release} definitions, as they have been dropped with v4.8 Ref: https://github.com/torvalds/linux/commit/1fa64f198b9f8d6ec0f7aec7c18dc94684391140 Solves: -- snip -- TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/param.c: In function 'sess_param_check': TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/param.c:48:41: error: 'PAGE_CACHE_SIZE' undeclared (first use in this function) (u32) ((ISCSI_CONN_IOV_MAX - 1) * PAGE_CACHE_SIZE)); ^ -- snip -- 3. Replace crypto_hash interfaces with crypto_ahash interfaces, Ref: https://github.com/torvalds/linux/commit/896545098777564212b9e91af4c973f094649aa7 Ref: https://www.redhat.com/archives/dm-devel/2016-January/msg00244.html Solves: -- snip -- TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/digest.c: In function 'digest_init': TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/digest.c:42:23: error: implicit declaration of function 'crypto_alloc_hash' [-Werror=implicit-function-declaration] conn->rx_hash.tfm = crypto_alloc_hash("crc32c", 0, ^~~~~~~~~~~~~~~~~ TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/digest.c: In function 'digest_cleanup': TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/digest.c:77:3: error: implicit declaration of function 'crypto_free_hash' [-Werror=implicit-function-declaration] crypto_free_hash(conn->tx_hash.tfm); ^~~~~~~~~~~~~~~~ -- snip -- 4. The earlier "rw" parameter has been set in "bi_rw" within bio structure, hence remove "rw" argument. Ref: https://github.com/torvalds/linux/commit/4e49ea4a3d276365bf7396c9b77b4d1d5923835a Solves: -- snip -- TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/block-io.c:140:14: warning: passing argument 1 of 'submit_bio' makes pointer from integer without a cast [-Wint-conversion] submit_bio(rw, bio); ^~ -- snip -- 5. The 'len' argument from sk_data_ready() callback has been removed in linux kernel v4.3 and above. Ref: https://github.com/torvalds/linux/commit/676d23690fb62b5d51ba5d659935e9f7d9da9f8e Solves: -- snip -- TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/conn.c: In function 'iet_socket_bind': TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/conn.c:143:38: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types] target->nthread_info.old_data_ready = conn->sock->sk->sk_data_ready; ^ TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/conn.c:144:32: error: assignment from incompatible pointer type [-Werror=incompatible-pointer-types] conn->sock->sk->sk_data_ready = iet_data_ready; ^ -- snip -- 6. A. The "size" argument has been dropped from sock_recvmsg syscall in v4.8, as all callers have it equal to msg_data_left(msg). B. 'struct user_msghdr' is being used for userland-side msghdr instead of 'struct msghdr', which is used for kernel-side msghdr in linux v3.19 and above, so typecase it while calling sock_recvmsg syscall. Ref: https://github.com/torvalds/linux/commit/2da62906b1e298695e1bb725927041cd59942c98 https://github.com/torvalds/linux/commit/666547ff591cebdedc4679bf6b1b3f3383a8dea3 Solves: -- snip -- TOPDIR/tmp-glibc/work-shared/qemux86/kernel-source/include/linux/net.h:222:5: note: expected 'struct msghdr *' but argument is of type 'struct user_msghdr *' int sock_recvmsg(struct socket *sock, struct msghdr *msg, int flags); ^~~~~~~~~~~~ TOPDIR/tmp-glibc/work/qemux86-oe-linux/iscsitarget/1.4.20.3+svn502-r0/iscsitarget-1.4.20.3+svn502/kernel/nthread.c:129:8: error: too many arguments to function 'sock_recvmsg' res = sock_recvmsg(conn->sock, &msg, len, MSG_DONTWAIT | MSG_NOSIGNAL); ^~~~~~~~~~~~ -- snip -- Detailed error log is at: http://errors.yoctoproject.org/Errors/Details/83334/ Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb')
-rw-r--r--meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb b/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb
index 4b5622b6e8..7279bc6378 100644
--- a/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb
+++ b/meta-networking/recipes-extended/iscsitarget/iscsitarget_1.4.20.3+svn502.bb
@@ -12,7 +12,8 @@ SRC_URI = "http://ftp.heanet.ie/mirrors/ubuntu/pool/universe/i/${BPN}/${BPN}_${P
file://use-kernel-makefile-to-get-kernel-version.patch \
file://fix-errors-observed-with-linux-3.19-and-greater.patch \
file://access-sk_v6_daddr-iff-IPV6-defined.patch \
- file://build_with_updated_bio_struct_of_linux_v4.3_and_above.patch"
+ file://build_with_updated_bio_struct_of_linux_v4.3_and_above.patch \
+ file://build_with_updated_interfaces_of_linux_v4.8_and_above.patch"
SRC_URI[md5sum] = "ef9bc823bbabd3c772208c00d5f2d089"
SRC_URI[sha256sum] = "d3196ccb78a43266dce28587bfe30d8ab4db7566d7bce96057dfbb84100babb5"
@@ -56,6 +57,3 @@ FILES_${PN} += "${sbindir} \
RDEPENDS_${PN} = "kernel-module-iscsi-trgt"
RRECOMMENDS_${PN} = "kernel-module-crc32c kernel-module-libcrc32c"
-
-# http://errors.yoctoproject.org/Errors/Details/83334/
-PNBLACKLIST[iscsitarget] ?= "BROKEN: not compatible with default kernel version 4.8"