aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-11-27 20:10:31 -0300
committerKhem Raj <raj.khem@gmail.com>2020-11-27 22:28:31 -0800
commit666a8b94a34c0248b02f37136ae052ca36e6b428 (patch)
treefea644c318fd529ca674bf77ccf6de70dec396bb /meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb
parent12180d4bc2932707156695d3cfc48ce871eaa62c (diff)
downloadmeta-openembedded-contrib-666a8b94a34c0248b02f37136ae052ca36e6b428.tar.gz
wireguard-module: upgrade 1.0.20200908 -> 1.0.20201112
Relevant changes: - fe40226 version: bump - d0bf51b qemu: bump default testing version - ce8faa3 compat: SYM_FUNC_{START,END} were backported to 5.4 - da5646f qemu: drop build support for rhel 8.2 - 99e954f netns: check that route_me_harder packets use the right sk - 25320ac noise: take lock when removing handshake entry from table Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb
new file mode 100644
index 0000000000..c540445d7e
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20201112.bb
@@ -0,0 +1,40 @@
+require wireguard.inc
+
+SRCREV = "fe402261666821514377d06c2c68ed9bc19e7634"
+
+SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat"
+
+inherit module kernel-module-split
+
+DEPENDS = "virtual/kernel libmnl"
+
+# This module requires Linux 3.10 higher and several networking related
+# configuration options. For exact kernel requirements visit:
+# https://www.wireguard.io/install/#kernel-requirements
+
+EXTRA_OEMAKE_append = " \
+ KERNELDIR=${STAGING_KERNEL_DIR} \
+ "
+
+MAKE_TARGETS = "module"
+
+RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
+MODULE_NAME = "wireguard"
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+PKG_${PN} = "kernel-module-${MODULE_NAME}"
+
+module_do_install() {
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
+ install -m 0644 ${MODULE_NAME}.ko \
+ ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
+}
+
+# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
+# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
+# for reference machines e.g. qemu
+EXCLUDE_FROM_WORLD = "1"