aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-protocols
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb2
-rw-r--r--meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb18
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga.inc16
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc26
-rw-r--r--meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb12
5 files changed, 37 insertions, 37 deletions
diff --git a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb b/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
index d17cc78a12..a7c10f797e 100644
--- a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
+++ b/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
@@ -23,7 +23,7 @@ EXTRA_OECMAKE = " \
-DLOG_PGSQL=FALSE \
-DRADIUS=FALSE \
-DNETSNMP=FALSE \
- "
+"
FILES_${PN}-dbg += "/usr/lib/${BPN}/.debug/*"
PACKAGES =+ "${PN}-libs"
diff --git a/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
index c173af4340..6a90578bc6 100644
--- a/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
+++ b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
@@ -1,9 +1,9 @@
SUMMARY = "Client for Microsoft PPTP VPNs"
DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
- and OpenBSD client for the proprietary Microsoft Point-to-Point \
- Tunneling Protocol, PPTP. Allows connection to a PPTP based \
- Virtual Private Network (VPN) as used by employers and some \
- cable and ADSL internet service providers."
+ and OpenBSD client for the proprietary Microsoft Point-to-Point \
+ Tunneling Protocol, PPTP. Allows connection to a PPTP based \
+ Virtual Private Network (VPN) as used by employers and some \
+ cable and ADSL internet service providers."
HOMEPAGE = "http://pptpclient.sourceforge.net"
SECTION = "network"
LICENSE = "GPLv2+"
@@ -14,7 +14,7 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
file://options.pptp \
file://fix-parallel-build.patch \
- "
+"
SRC_URI[md5sum] = "4c3d19286a37459a632c7128c92a9857"
SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d37694bc"
@@ -22,10 +22,10 @@ SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d3
S = "${WORKDIR}/pptp-${PV}"
do_install() {
- install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
- install -m 555 pptp ${D}${sbindir}
- install -m 644 pptp.8 ${D}${mandir}/man8
- install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
+ install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
+ install -m 555 pptp ${D}${sbindir}
+ install -m 644 pptp.8 ${D}${mandir}/man8
+ install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
}
RDEPENDS_${PN} = "ppp"
diff --git a/meta-networking/recipes-protocols/quagga/quagga.inc b/meta-networking/recipes-protocols/quagga/quagga.inc
index b40c858037..160c458cce 100644
--- a/meta-networking/recipes-protocols/quagga/quagga.inc
+++ b/meta-networking/recipes-protocols/quagga/quagga.inc
@@ -136,33 +136,33 @@ pkg_postinst_${PN} () {
# Stop apps before uninstall
pkg_prerm_${PN} () {
- ${sysconfdir}/init.d/quagga stop
+ ${sysconfdir}/init.d/quagga stop
}
pkg_prerm_${PN}-ospfd () {
- ${sysconfdir}/init.d/quagga stop ospfd
+ ${sysconfdir}/init.d/quagga stop ospfd
}
pkg_prerm_${PN}-ospf6d () {
- ${sysconfdir}/init.d/quagga stop ospf6d
+ ${sysconfdir}/init.d/quagga stop ospf6d
}
pkg_prerm_${PN}-babeld () {
- ${sysconfdir}/init.d/quagga stop babeld
+ ${sysconfdir}/init.d/quagga stop babeld
}
pkg_prerm_${PN}-bgpd () {
- ${sysconfdir}/init.d/quagga stop bgpd
+ ${sysconfdir}/init.d/quagga stop bgpd
}
pkg_prerm_${PN}-ripd () {
- ${sysconfdir}/init.d/quagga stop ripd
+ ${sysconfdir}/init.d/quagga stop ripd
}
pkg_prerm_${PN}-ripngd () {
- ${sysconfdir}/init.d/quagga stop ripngd
+ ${sysconfdir}/init.d/quagga stop ripngd
}
pkg_prerm_${PN}-isisd () {
- ${sysconfdir}/init.d/quagga stop isisd
+ ${sysconfdir}/init.d/quagga stop isisd
}
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
index cea542732a..f4ea2b8266 100644
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
+++ b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
@@ -15,22 +15,22 @@ S = "${WORKDIR}/git"
inherit update-rc.d
do_compile () {
- oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
+ oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
}
do_install () {
- oe_runmake PREFIX="${D}${prefix}" install
-
- install -d ${D}${sysconfdir}/init.d
- touch ${D}${sysconfdir}/xl2tpd.conf
- install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
- sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
- sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
- sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
- sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
-
- install -d ${D}${sysconfdir}/default
- install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
+ oe_runmake PREFIX="${D}${prefix}" install
+
+ install -d ${D}${sysconfdir}/init.d
+ touch ${D}${sysconfdir}/xl2tpd.conf
+ install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
+ sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
+ sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
+ sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
+ sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
+
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
}
CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"
diff --git a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
index f755940f1e..9307263c7b 100644
--- a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
+++ b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
@@ -25,10 +25,10 @@ SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2"
SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b"
do_install () {
- install -d ${D}${sbindir}
- install -d ${D}${sysconfdir}/network/if-up.d
- install -d ${D}${sysconfdir}/default
- install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
- install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
- install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}/network/if-up.d
+ install -d ${D}${sysconfdir}/default
+ install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
+ install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
+ install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
}