aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/cifs
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-02-18 06:31:11 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-18 18:17:20 -0800
commit5de43a6f0db09b7804fe9d3588211099a8bea9e4 (patch)
tree23f10afa8c91e86af6aeee376312d04207a92bcf /meta-networking/recipes-support/cifs
parentafa8a4e9ca47fbdcee5469c7dc2266a5ee2536b9 (diff)
downloadmeta-openembedded-contrib-5de43a6f0db09b7804fe9d3588211099a8bea9e4.tar.gz
cifs-utils: upgrade 6.9 -> 6.10
add the following patch to solve build error: 0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch Error message: (cd /sbin && ln -sf mount.cifs mount.smb3) /yocto/work001/fnst/wangmy/build/tmp/hosttools/install -c mount.cifs '/yocto/work001/fnst/wangmy/build/tmp/work/core2-64-poky-linux/cifs-utils/6.10-r0/image/sbin' make install-data-hook ln: failed to create symbolic link 'mount.smb3': Permission denied Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/cifs')
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch43
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_6.10.bb (renamed from meta-networking/recipes-support/cifs/cifs-utils_6.9.bb)8
2 files changed, 49 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch b/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch
new file mode 100644
index 0000000000..233ae40ce0
--- /dev/null
+++ b/meta-networking/recipes-support/cifs/cifs-utils/0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch
@@ -0,0 +1,43 @@
+From f61f5f8a328207867b5c523b1c6bef6aaecaab88 Mon Sep 17 00:00:00 2001
+From: Wang Mingyu <wangmy@cn.fujitsu.com>
+Date: Sat, 15 Feb 2020 16:05:58 +0800
+Subject: [PATCH] Bugfix: Modify the dir of install-exec-hook and
+ install-data-hook
+
+Error message:
+(cd /sbin && ln -sf mount.cifs mount.smb3)
+ /yocto/work001/fnst/wangmy/build/tmp/hosttools/install -c mount.cifs
+'/yocto/work001/fnst/wangmy/build/tmp/work/core2-64-poky-linux/cifs-utils/6.10-r0/image/sbin'
+make install-data-hook
+ln: failed to create symbolic link 'mount.smb3': Permission denied
+
+Upstream-Status: Pending
+
+Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
+---
+ Makefile.am | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index fe9cd34..e9be6b3 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -119,11 +119,11 @@ endif
+ SUBDIRS = contrib
+
+ install-exec-hook:
+- (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
++ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
+
+ install-data-hook:
+- (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
++ (test -n "$(man_MANS)" || exit 0; cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
+
+ uninstall-hook:
+- (cd $(ROOTSBINDIR) && rm -f $(ROOTSBINDIR)/mount.smb3)
+- (cd $(man8dir) && rm -f $(man8dir)/mount.smb3.8)
++ (cd $(DESTDIR)$(ROOTSBINDIR) && rm -f $(DESTDIR)$(ROOTSBINDIR)/mount.smb3)
++ (test -n "$(man_MANS)" || exit 0; cd $(DESTDIR)$(man8dir) && rm -f $(DESTDIR)$(man8dir)/mount.smb3.8)
+--
+2.17.1
+
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_6.9.bb b/meta-networking/recipes-support/cifs/cifs-utils_6.10.bb
index 51dcb23d11..8d82ee4546 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_6.9.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_6.10.bb
@@ -4,9 +4,9 @@ SECTION = "otherosfs"
LICENSE = "GPLv3 & LGPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-PV = "6.9"
+PV = "6.10"
-SRCREV = "9a8c21ad9e4510a83a3a41f7a04f763a4fe9ec09"
+SRCREV = "5ff5fc2ecc10353fd39ad508db5c2828fd2d8d9a"
SRC_URI = "git://git.samba.org/cifs-utils.git"
S = "${WORKDIR}/git"
@@ -22,6 +22,10 @@ PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samb
PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
+SRC_URI += " \
+ file://0001-Bugfix-Modify-the-dir-of-install-exec-hook-and.patch \
+ "
+
inherit autotools pkgconfig
do_install_append() {