aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dnsmasq
diff options
context:
space:
mode:
authorShrikant Bobade <Shrikant_Bobade@mentor.com>2014-08-04 14:42:57 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-10 16:07:17 +0200
commit3740ef263860f6fc94305f32253b1a4e9338e3b9 (patch)
tree78d5ca2f2d68560acece1dc05d1fff2904ad949b /meta-networking/recipes-support/dnsmasq
parent6576cddf6b66c34e9ea550d8dd0819c559237b5a (diff)
downloadmeta-openembedded-contrib-3740ef263860f6fc94305f32253b1a4e9338e3b9.tar.gz
dnsmasq: fix parallel make failure
The dnsmasq target depends on .configured and $(objs). .configured does an rm -f *.o. Yet the only thing telling make to build the .configured target before the $(objs) target was the order of the dependencies of the dnsmasq target. We can't rely on that order when doing a paralllel make build, so add an explicit rule to enforce that order. Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Shrikant Bobade <Shrikant_Bobade@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/dnsmasq')
-rw-r--r--meta-networking/recipes-support/dnsmasq/dnsmasq.inc1
-rw-r--r--meta-networking/recipes-support/dnsmasq/files/parallel-make.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
index e57ab727eb..1955d6fef6 100644
--- a/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
+++ b/meta-networking/recipes-support/dnsmasq/dnsmasq.inc
@@ -11,6 +11,7 @@ SRC_URI = "http://www.thekelleys.org.uk/dnsmasq/${@['archive/', ''][float(d.getV
file://init \
file://dnsmasq.conf \
file://dnsmasq.service \
+ file://parallel-make.patch \
"
inherit update-rc.d systemd
diff --git a/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch
new file mode 100644
index 0000000000..3d1040cf3b
--- /dev/null
+++ b/meta-networking/recipes-support/dnsmasq/files/parallel-make.patch
@@ -0,0 +1,18 @@
+The dnsmasq target depends on .configured and $(objs). .configured does an rm
+-f *.o. Yet the only thing telling make to build the .configured target before
+the $(objs) target was the order of the dependencies of the dnsmasq target. We
+can't rely on that order when doing a paralllel make build, so add an explicit
+rule to enforce that order.
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+
+--- dnsmasq-2.68.orig/Makefile
++++ dnsmasq-2.68/Makefile
+@@ -139,6 +139,8 @@ bloatcheck : $(BUILDDIR)/dnsmasq_baselin
+ @rm -f *.o
+ @touch $@
+
++$(objs): .configured
++
+ $(objs:.o=.c) $(hdrs):
+ ln -s $(top)/$(SRC)/$@ .