aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/mtr
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-27 11:25:53 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-11-27 14:43:59 -0500
commit24289982628563ce6c49a8dc207c2a1cbd9167b3 (patch)
tree2a37c76a865db0f777f3d3fc2a8de0cb3014c944 /meta-networking/recipes-support/mtr
parent3d851fe4cec6f3c166c9fb76e767265dbeab5b69 (diff)
downloadmeta-openembedded-contrib-24289982628563ce6c49a8dc207c2a1cbd9167b3.tar.gz
mtr: add from OE-Classic, update and tidy up
* Update to 0.82 * Add ncurses to DEPENDS * Add patch to fix configure with standard autotools_do_configure * Add SUMMARY * Add LIC_FILES_CHKSUM Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-networking/recipes-support/mtr')
-rw-r--r--meta-networking/recipes-support/mtr/files/no-gtk.patch31
-rw-r--r--meta-networking/recipes-support/mtr/mtr_0.82.bb19
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/mtr/files/no-gtk.patch b/meta-networking/recipes-support/mtr/files/no-gtk.patch
new file mode 100644
index 0000000000..0dbeb7a297
--- /dev/null
+++ b/meta-networking/recipes-support/mtr/files/no-gtk.patch
@@ -0,0 +1,31 @@
+Disable gtk check that breaks with current autotools
+
+Ideally we would have a proper fix for this and send that upstream instead.
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+diff --git a/configure.in b/configure.in
+index 8474543..5118565 100644
+--- a/configure.in
++++ b/configure.in
+@@ -48,16 +48,8 @@ AC_ARG_ENABLE(ipv6,
+ [ --disable-ipv6 Do not enable IPv6],
+ WANTS_IPV6=$enableval, WANTS_IPV6=yes)
+
+-if test "x$WANTS_GTK" = "xyes"; then
+- AM_PATH_GTK_2_0(2.6.0, CFLAGS="$CFLAGS $GTK_CFLAGS"
+- LIBS="$LIBS $GTK_LIBS -lm",
+- AC_MSG_WARN(Building without GTK2 display support)
+- AC_DEFINE(NO_GTK, 1, [Define if you don't have the GTK+ libraries available.])
+- GTK_OBJ="")
+-else
+- AC_DEFINE(NO_GTK)
+- GTK_OBJ=""
+-fi
++AC_DEFINE(NO_GTK, 1, [Define if you don't have the GTK+ libraries available.])
++GTK_OBJ=""
+
+ AC_CHECK_FUNC(socket, ,
+ AC_CHECK_LIB(socket, socket, , AC_MSG_ERROR(No socket library found)))
diff --git a/meta-networking/recipes-support/mtr/mtr_0.82.bb b/meta-networking/recipes-support/mtr/mtr_0.82.bb
new file mode 100644
index 0000000000..c6d5152148
--- /dev/null
+++ b/meta-networking/recipes-support/mtr/mtr_0.82.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Combined traceroute and ping utility"
+DESCRIPTION = "mtr combines the functionality of the 'traceroute' and 'ping' programs in a single network diagnostic tool."
+HOMEPAGE = "http://www.bitwizard.nl/mtr/"
+DEPENDS = "ncurses"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+ file://mtr.c;startline=5;endline=16;md5=87105f8fe9675e897e074869afaafa6f"
+
+SRC_URI = "ftp://ftp.bitwizard.nl/mtr/mtr-${PV}.tar.gz \
+ file://no-gtk.patch"
+
+SRC_URI[md5sum] = "10601ea543fda3e51545c4bce195b64c"
+SRC_URI[sha256sum] = "f3b457c9623ae03565688a7ffd49d4843a5e2505ccaf3ba8d9fbd86e3ce9b6a0"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-gtk"
+