aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcf/gnulib_git.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-03-14 16:36:47 +0800
committerJoe MacDonald <joe@deserted.net>2014-03-14 08:51:44 -0400
commit60c49640554b62afc8c9e5ce54db93b76b03f6c3 (patch)
treed4a67da9442a5db768e8b38a5da680900fd0f468 /meta-networking/recipes-support/netcf/gnulib_git.bb
parent5c9849cd39422ba28f217ba954cdde859a3fe75b (diff)
downloadmeta-openembedded-contrib-60c49640554b62afc8c9e5ce54db93b76b03f6c3.tar.gz
netcf: fix offline rebuilding failed
The netcf downloaded gnulib source to ${S} at the configure time, while the network disconnected, if sstate cache was cleaned, the netcf rebuilding failed. Added a new recipe named 'gnulib' to download gnulib source to ${GITDIR} and populate it to the staging data dir. So netcf could specify this local directory where gnulib sources reside to save the bandwidth downloading. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support/netcf/gnulib_git.bb')
-rw-r--r--meta-networking/recipes-support/netcf/gnulib_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcf/gnulib_git.bb b/meta-networking/recipes-support/netcf/gnulib_git.bb
new file mode 100644
index 0000000000..730f5cd789
--- /dev/null
+++ b/meta-networking/recipes-support/netcf/gnulib_git.bb
@@ -0,0 +1,35 @@
+SUMMARY = "The GNU portability library"
+DESCRIPTION = "A collection of software subroutines which are designed to \
+be usable on many operating systems. The goal of the project \
+is to make it easy for free software authors to make their \
+software run on many operating systems. Since source is designed \
+to be copied from gnulib, it is not a library per-se, as much \
+as a collection of portable idioms to be used in other projects."
+
+HOMEPAGE = "http://www.gnu.org/software/gnulib/"
+SECTION = "libs"
+LICENSE = "LGPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=e4cf3810f33a067ea7ccd2cd889fed21"
+SRCREV = "24379a9217fa4bd62685795aaaa010fd90ced9e3"
+SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
+"
+S = "${WORKDIR}/git"
+
+# Git clone a copy of gnulib source to the staging data dir
+sysroot_stage_all () {
+ [ -d ${STAGING_DATADIR}/gnulib/ ] && rm -rf ${STAGING_DATADIR}/gnulib/
+ cd ${S}
+ git checkout master
+ git clone ${S} ${STAGING_DATADIR}/gnulib
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_install[noexec] = "1"
+do_package[noexec] = "1"
+do_packagedata[noexec] = "1"
+do_package_write_ipk[noexec] = "1"
+do_package_write_deb[noexec] = "1"
+do_package_write_rpm[noexec] = "1"