aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2016-11-14 15:49:03 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-05 13:49:55 -0500
commit81e0a57b367a67998028d8f403136e5cab7817d4 (patch)
tree31a69c76f79a99a48877ddc5502906a7e1417758 /meta-networking/recipes-support/open-isns/open-isns_0.97.bb
parent18d518a03d7d55b69f7ff4b19916c7006220c3e9 (diff)
downloadmeta-openembedded-contrib-joeythesaint/meta-networking-next.tar.gz
iscsi-initiator-utils: Update to 2.0.874joeythesaint/meta-networking-next
The latest iscsi-initiator-utils has been available for a while now, update our recipe. The new version no longer bundles its own ISNS server, so this update brings in open-isns as a dependency. As open-isns depends on systemd, add systemd to REQUIRED_DISTRO_FEATURES Additionally, open-iscsi.org is defunct, the new home is at open-iscsi.com, update the SRC_URI and homepage accordingly. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/open-isns/open-isns_0.97.bb')
-rw-r--r--meta-networking/recipes-support/open-isns/open-isns_0.97.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-isns/open-isns_0.97.bb b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
new file mode 100644
index 0000000000..828d1166de
--- /dev/null
+++ b/meta-networking/recipes-support/open-isns/open-isns_0.97.bb
@@ -0,0 +1,35 @@
+# Copyright (C) 2016 Joe MacDonald <joe_macdonald@mentor.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "iSNS daemon and utility programs"
+DESCRIPTION = "This is a partial implementation of RFC4171, the Internet \
+Storage Name Service (iSNS). The distribution includes the iSNS server, \
+supporting persisten storage of registrations, isnsadm, a command line \
+utility for managing nodes, and isnsdd, a corresponding discovery daemon."
+HOMEPAGE = "http://github.com/gonzoleeman/open-isns/"
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
+SECTION = "net"
+
+DEPENDS = "openssl systemd"
+
+SRC_URI = " \
+ git://github.com/open-iscsi/open-isns \
+"
+
+SRCREV ?= "09954404e948e41eb0fce8e28836018b4ce3d20d"
+
+S = "${WORKDIR}/git"
+
+inherit systemd autotools-brokensep distro_features_check
+# depends on systemd
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+EXTRA_OECONF = " --prefix=${prefix} --enable-shared"
+
+do_install_append () {
+ oe_runmake INCDIR=${D}${includedir}/libisns/ install_hdrs
+ oe_runmake LIBDIR=${D}${libdir} install_lib
+}
+
+FILES_${PN} += "${libdir}"