aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/spice/spice_git.bb
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2019-06-13 16:29:34 +0000
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:32 -0700
commitb47aae2d61e15ef4321e96487e3a2f83c115e9b3 (patch)
treea4437d001545571c2f6f571deeb88403a85bb62e /meta-networking/recipes-support/spice/spice_git.bb
parent26a390305c827b038c942d3faf8b2ba32c847e5a (diff)
downloadmeta-openembedded-contrib-b47aae2d61e15ef4321e96487e3a2f83c115e9b3.tar.gz
spice: fix compile errors on 32bit system
There are folowing compile errors on Linux 32bit system: red-channel.c:207:73: error: format '%x' expects argument of type 'unsigned int', but argument 7 has type 'long unsigned int' [-Werror=format=] |207| red_channel_debug(self, "thread_id 0x%" G_GSIZE_MODIFIER "x", ~~~~~~~~~~~~~~~~~~~~~^ self->priv->thread_id); ~~~~~~~~~~~~~~~~~~~~~^ On 32bit system, #define G_GSIZE_MODIFIER "". But the type of 'self->priv->thread_id' is 'unsigned long int' which should match '%lx' not '%x'. So we should recovery the <0x%" G_GSIZE_MODIFIER "x"> to <0x%lx">. And others files modification are similar to G_GSIZE_MODIFIER. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/spice/spice_git.bb')
-rw-r--r--meta-networking/recipes-support/spice/spice_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/spice/spice_git.bb b/meta-networking/recipes-support/spice/spice_git.bb
index 6249b0422b..3c45d1f5e1 100644
--- a/meta-networking/recipes-support/spice/spice_git.bb
+++ b/meta-networking/recipes-support/spice/spice_git.bb
@@ -24,6 +24,7 @@ SRC_URI = " \
git://anongit.freedesktop.org/spice/spice;name=spice \
git://anongit.freedesktop.org/spice/spice-common;destsuffix=git/subprojects/spice-common;name=spice-common \
file://0001-Convert-pthread_t-to-be-numeric.patch \
+ file://0001-Fix-compile-errors-on-Linux-32bit-system.patch \
"
S = "${WORKDIR}/git"