aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-07-08 13:20:47 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-07-20 23:57:27 -0400
commitbe2a2437005087b3f8d43a09ddc69991ed81e110 (patch)
treed5ebb9df219228d8b8f8b446deab6a89c9f267a5 /meta-networking/recipes-support/tcpdump/tcpdump-4.5.1
parentfb70d449341acebebd160dd4c2827c2b7cf46ea3 (diff)
downloadmeta-openembedded-contrib-be2a2437005087b3f8d43a09ddc69991ed81e110.tar.gz
Uprev tcpdump to 4.5.1
1. update the patch tcpdump_configure_no_-O2.patch 2. do not check libdlpi dependence on cross-compile, or else it will cause do_qa_configure to fail. 3. do not check libpcap dependence, since the libpcap has been added into DEPENDS, or else it will cause do_qa_configure to fail 4. make the check of getaddrinfo work on cross-compile Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/tcpdump/tcpdump-4.5.1')
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/0001-minimal-IEEE802.15.4-allowed.patch22
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/configure.patch29
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/ipv6-cross.patch41
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-configure-dlpi.patch31
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-cross-getaddrinfo.patch23
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump_configure_no_-O2.patch27
-rw-r--r--meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/unnecessary-to-check-libpcap.patch33
7 files changed, 206 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/0001-minimal-IEEE802.15.4-allowed.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/0001-minimal-IEEE802.15.4-allowed.patch
new file mode 100644
index 0000000000..9d3d60d4d7
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/0001-minimal-IEEE802.15.4-allowed.patch
@@ -0,0 +1,22 @@
+From: Sergey Lapin <slapin@slind.org>
+Date: Wed, 28 Jan 2009 16:34:15 +0300
+Subject: [PATCH] minimal IEEE802.15.4 allowed
+
+---
+ tcpdump.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/tcpdump.c b/tcpdump.c
+index 06683af..fbc944c 100644
+--- a/tcpdump.c
++++ b/tcpdump.c
+@@ -282,6 +282,9 @@ static struct printer printers[] = {
+ #ifdef DLT_MFR
+ { mfr_if_print, DLT_MFR },
+ #endif
++#ifdef DLT_IEEE802_15_4
++ { raw_if_print, DLT_IEEE802_15_4 },
++#endif
+ #if defined(DLT_BLUETOOTH_HCI_H4_WITH_PHDR) && defined(HAVE_PCAP_BLUETOOTH_H)
+ { bt_if_print, DLT_BLUETOOTH_HCI_H4_WITH_PHDR},
+ #endif
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/configure.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/configure.patch
new file mode 100644
index 0000000000..3697420fd3
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/configure.patch
@@ -0,0 +1,29 @@
+---
+ aclocal.m4 | 1 -
+ configure.in | 1 +
+ 2 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/aclocal.m4 b/aclocal.m4
+index 40b5866..0c662b0 100644
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -40,7 +40,6 @@ dnl
+ AC_DEFUN(AC_LBL_C_INIT_BEFORE_CC,
+ [AC_PREREQ(2.50)
+ AC_BEFORE([$0], [AC_LBL_C_INIT])
+- AC_BEFORE([$0], [AC_PROG_CC])
+ AC_BEFORE([$0], [AC_LBL_FIXINCLUDES])
+ AC_BEFORE([$0], [AC_LBL_DEVEL])
+ AC_ARG_WITH(gcc, [ --without-gcc don't use gcc])
+diff --git a/configure.in b/configure.in
+index 11257c9..7f9591c 100644
+--- a/configure.in
++++ b/configure.in
+@@ -19,6 +19,7 @@ AC_REVISION($Revision: 1.204 $)
+ AC_PREREQ(2.50)
+ AC_INIT(tcpdump.c)
+
++AC_PROG_CC
+ AC_CANONICAL_HOST
+
+ AC_LBL_C_INIT_BEFORE_CC(V_CCOPT, V_INCLS)
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/ipv6-cross.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/ipv6-cross.patch
new file mode 100644
index 0000000000..7eba2c5a6d
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/ipv6-cross.patch
@@ -0,0 +1,41 @@
+---
+ configure.in | 12 ++++++++----
+ 1 files changed, 8 insertions(+), 4 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index eb3e5e8..11257c9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -181,8 +181,9 @@ yes) AC_MSG_RESULT(yes)
+ ipv6=no
+ ;;
+ esac ],
+-
+- AC_TRY_RUN([ /* AF_INET6 available check */
++[
++ if test x"$cross_compiling" != "xyes"; then
++ AC_TRY_RUN([ /* AF_INET6 avalable check */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ main()
+@@ -201,7 +202,10 @@ main()
+ ipv6=no],
+ [ AC_MSG_RESULT(no)
+ ipv6=no]
+-))
++ )
++else
++ AC_MSG_FAILURE([Unable to check for ipv6 when crosscompiling, please specify.])
++fi])
+
+ ipv6type=unknown
+ ipv6lib=none
+@@ -316,7 +320,7 @@ if test "$ipv6" = "yes" -a "$ipv6lib" != "none"; then
+ fi
+
+
+-if test "$ipv6" = "yes"; then
++if test x"$cross_compiling" != "xyes" -a "$ipv6" = "yes"; then
+ #
+ # XXX - on Tru64 UNIX 5.1, there is no "getaddrinfo()"
+ # function in libc; there are "ngetaddrinfo()" and
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-configure-dlpi.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-configure-dlpi.patch
new file mode 100644
index 0000000000..50e2d54399
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-configure-dlpi.patch
@@ -0,0 +1,31 @@
+[PATCH] tcpdump: cross-compiling not check dlpi.
+
+For cross-compiling on Linux platforms, we do not need to check libdlpi
+since it is only placed on Solaris.
+Also, checking libdlpi in native /lib would cause do_qa_configure fail.
+
+Upstream-Status: Pending.
+
+Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
+---
+ configure.in | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 7f9591c..ca277c0 100644
+--- a/configure.in
++++ b/configure.in
+@@ -716,7 +716,9 @@ don't.])
+ fi
+
+ # libdlpi is needed for Solaris 11 and later.
+-AC_CHECK_LIB(dlpi, dlpi_walk, LIBS="$LIBS -ldlpi" LDFLAGS="-L/lib $LDFLAGS", ,-L/lib)
++if test "$cross_compiling" != yes; then
++ AC_CHECK_LIB(dlpi, dlpi_walk, LIBS="$LIBS -ldlpi" LDFLAGS="-L/lib $LDFLAGS", ,-L/lib)
++fi
+
+ dnl portability macros for getaddrinfo/getnameinfo
+ dnl
+--
+1.7.5.4
+
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-cross-getaddrinfo.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-cross-getaddrinfo.patch
new file mode 100644
index 0000000000..b414b72e9d
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump-cross-getaddrinfo.patch
@@ -0,0 +1,23 @@
+Fix getaddinfo check when cross compiling
+
+Upstream-Status: Pending.
+
+AC_TRY_RUN defaults to td_cv_buggygetaddrinfo=yes when
+cross-compiling. So this change indicates that we
+are cross-compiling.
+
+Signed-of-by: Aws Ismail <aws.ismail@windriver.com>
+
+diff --git a/configure.in b/configure.in
+index ca277c0..283035e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -434,7 +434,7 @@ main()
+ ],
+ td_cv_buggygetaddrinfo=no,
+ td_cv_buggygetaddrinfo=yes,
+- td_cv_buggygetaddrinfo=yes)])
++ td_cv_buggygetaddrinfo=cross)])
+ if test "$td_cv_buggygetaddrinfo" = no; then
+ AC_MSG_RESULT(good)
+ else
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump_configure_no_-O2.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump_configure_no_-O2.patch
new file mode 100644
index 0000000000..b2296bc524
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/tcpdump_configure_no_-O2.patch
@@ -0,0 +1,27 @@
+---
+ configure | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index 468a517..a890728 100755
+--- a/configure
++++ b/configure
+@@ -3036,13 +3036,13 @@ if test "$ac_test_CFLAGS" = set; then
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g"
+ else
+ CFLAGS="-g"
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=
+ else
+ CFLAGS=
+ fi
+--
+1.7.9.5
+
diff --git a/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/unnecessary-to-check-libpcap.patch b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/unnecessary-to-check-libpcap.patch
new file mode 100644
index 0000000000..d7a3ac23b1
--- /dev/null
+++ b/meta-networking/recipes-support/tcpdump/tcpdump-4.5.1/unnecessary-to-check-libpcap.patch
@@ -0,0 +1,33 @@
+unnecessary to check libpcap
+
+Upstream-Status: Pending
+
+since the check of libpcap did not consider the cross-compile, lead to the
+below error:
+ This autoconf log indicates errors, it looked at host include and/or
+ library paths while determining system capabilities.
+
+In fact, the libpcap has been added into the tcpdump's DEPENDS, not need to
+check if libpcap existed.
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index 06fade1..9125de7 100644
+--- a/configure.in
++++ b/configure.in
+@@ -567,7 +567,7 @@ AC_SEARCH_LIBS(getrpcbynumber, nsl,
+ dnl AC_CHECK_LIB(z, uncompress)
+ dnl AC_CHECK_HEADERS(zlib.h)
+
+-AC_LBL_LIBPCAP(V_PCAPDEP, V_INCLS)
++#AC_LBL_LIBPCAP(V_PCAPDEP, V_INCLS)
+
+ #
+ # Check for these after AC_LBL_LIBPCAP, so we link with the appropriate
+--
+1.7.9.5
+